I am trying to upgrade to a new Ubuntu version but the update manager does not recognize an update. Why not?

  • which commands do you use to upgrade? Apr 26, 2013 at 5:17

6 Answers 6


Because Ubuntu 12.04 is a Long Term Support release (meaning that it is supported with bug fixes and security updates for 5 years) you won’t find a pop-up telling you that a new version is available.

If you want to upgrade,you can follow these instructions

  1. Open Update Manager from either the Power Menu or the Dash.
  2. Click the ‘Settings’ button in the lower-left corner of the Update Manager window: This will open Software Sources.
  3. Click the menu next to “Notify me of a new Ubuntu version” and select ‘For Any New Version’

enter image description here

  1. Important DO NOT uncheck or alter anything other than the above.

Once you’ve made the change you will likely be prompted to input your user password. After this, close Software Sources, then close and then reopen Update Manager.

. Click the ‘Upgrade’ button to begin your upgrade to Ubuntu 12.10.

source: OMG Ubuntu

  • What can be done so that the new version is also found when using "sudo apt-get dist-upgrade"? I typically use that, not the update manager. But I just checked, the update manager finds 12.10, on the command line it is not found. Oct 19, 2012 at 13:53
  • 1
    Marius, the 'do-release-upgrade' command is set up for that. 'dist-upgrade' will only upgrade you to a new version if you have also already changed all of your references in /etc/apt/sources.list to the new distro.
    – AvatarKava
    Oct 22, 2012 at 11:15
  • Wow, this is surprisingly hard to find, particularly given that you actually have to quit the thing after telling it what you want. And especially on my netbook, where the "settings" button isn't visible because the update manager window is too large for the display. And there is no menu. I wonder what fraction of users are expected to ever upgrade from an LTS to another non-LTS version?
    – nealmcb
    Jan 6, 2013 at 22:48

You can also force it to check for development versions (since Quantal is released this won't really make any significant difference for you) by opening a terminal and typing:

update-manager -d &
  • @Gal Weinstock. If one of the answers solved your problem please accept the one that did. This will help other users. Nov 6, 2012 at 10:15

open Software Sources application (you can find it in the Dock) and go to the Updates tab

You should choose the option For any new version

enter image description here

Then press [Alt] + [F2] and type update-manager -d

Update Manager should offer you an upgrade to the new version.


Run this command in the terminal:

sudo do-release-upgrade

That will do the same as running it GUI :)

  • Thank you! i tried that before and it didn't work... i don't know but it worked this time! Nov 29, 2012 at 19:10
  • Glad to know it works :D
    – MiJyn
    Nov 29, 2012 at 19:11

The easiest way to upgrade from 12.10 to 13.04, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below:

sudo do-release-upgrade -d
  • yp , i tried it bt its showing, "no new release found"
    – peter
    Apr 26, 2013 at 6:12
  • I just tried it right after I put it my answer, and it did work. Does it give any errors?
    – Mitch
    Apr 26, 2013 at 6:19
  • kk, its not giving ny error ny way i m goin to format and instal, and hws it 13.04??
    – peter
    Apr 26, 2013 at 6:24
  • What have you changed in the manager settings?
    – Mitch
    Apr 26, 2013 at 6:27
  • jst that notifing optn
    – peter
    Apr 26, 2013 at 7:32

Please try this first:



Then, it will verbose detail information and possible errors. As in my case, the error is authorization error caused by setting a proxy in Synaptic Manager that need authorization. Disable the proxy solves my problem.

Hope you can find a solution to your problem too.

  • Thanks - this is exactly what I needed! I ran into an issue with a LAN->wifi adapter not connecting correctly, and this returned an HTML page as a response for the metadata cache. Removing the cached file and re-running do-release-upgrade worked.
    – Robert Hui
    Sep 20, 2013 at 8:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .