I'm trying hard to switch to Linux from Windows because of my engineering project. Unfortunately, everything is against that change!

  1. Before I have installed Broadcom STA proprietary drivers, I was seeing on NetworkManager and nm-applet only local radio-internet-access networks.
  2. After I installed Broadcom STA, I see my neighbor's wireless network (channel 11, WEP)
  3. Neither before nor after the installation is own wireless network available.

Computer: Asus Lamborghini VX6
Ubuntu: 12.04 LTS 64-bit
Router: ASUS N55U (A1) with newest AsusWRT firmware
Network: Channel 5 (tried also 10 and 11, both on 20 and 40MHz bands), WPA2 Personal, 2,4 + 5 GHz (what is not very important, 'cause the wlan card in VX6 is only 2,4GHz).

Network works fine on Windows, also through D-Link repeater on the other floor. Unfortunately, same network is invisible to Ubuntu on same machine.

I have tried some combinations with other GUIs but it did not work. Are there any better drivers for Ubuntu?

I need that network badly, but I'm an Ubuntu newbie, so I don't know how to solve that problem. Please help.

  • 1
    If there are a number of wireless networks, there might be an entry - last in the list - with an arrow to show "More Networks." If so, you might find your own network there (I sometimes find mine there, too). – Kelley Oct 18 '12 at 22:12
  • Did you try the networkmanager selection "Connect to hidden network"? and enter your essid and key? After the first time, you should connect automaticaly -- if not, in network manager, edit connections, and select your and add "connect automatically". – ubfan1 Oct 18 '12 at 22:51
  • Yep, I've tried to force that network. Didn't work. Asks for authentication every 2 minutes of trying to connect. The joke is, that the SSID isn't hidden :P – Chris Oct 19 '12 at 11:28

Solved. Linux sux at wireless drivers, 'cause a lot of them has a limit of 11 channels out of 13 available. Moreover, even the network working in 40MHz mode, is ivisible, untill the first channel is under 5. 20MHz mode works from channel 1 to 11.

What's more amazing, is that my network, working on channel 5 now is recognised by Ubuntu as channel 7...

Question to drivers programmers and all that stuff: are you insane to make it different than in router that works on same type of kernel and is fully compatibile with e.g. Windows? -.-

  • Ta muchly, was having the same problem! – KJ Tsanaktsidis Oct 28 '12 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.