So, I was just installing the WiFi on my Quantal install and what I got is this:

Unpacking replacement bcmwl-kernel-source ...
Setting up bcmwl-kernel-source ( ...
Loading new bcmwl- DKMS files...
Building only for 3.5.0-17-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
ERROR: Module b43 does not exist in /proc/modules
ERROR: Module b43legacy does not exist in /proc/modules
ERROR: Module ssb does not exist in /proc/modules
ERROR: Module bcm43xx does not exist in /proc/modules
ERROR: Module brcm80211 does not exist in /proc/modules
ERROR: Module brcmfmac does not exist in /proc/modules
ERROR: Module brcmsmac does not exist in /proc/modules
ERROR: Module bcma does not exist in /proc/modules
FATAL: Module wl not found.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...

In 11.10 and 12.04 the installation of the "bcmwl-kernel-source" worked like a charm and I had WiFI, but on 12.10 that's (sadly) not the case.

Anyone feeling like giving me a hand? :)

Needless to say I will provide any additional info if needed :)

  • Can you show which packages you installed and how? I'm having the same exact problem, but when I try to do- sudo apt-get install linux-sources linux-headers-3.5.0-17-generic, I get- E: Unable to locate package linux-sources – Ross Kinsman Oct 22 '12 at 3:29
  • This question should probably be a comment on the previous answer, however, try the following in a Terminal: – rft183 Oct 23 '12 at 18:27
  • 'sudo apt-get update' then 'sudo apt-get install linux-source linux-headers-generic'. I made a couple changes; one is that it is linux-source without the 's'. The other change (to linux-headers-generic) should make it so that if the kernel upgrades, you do not have to reinstall. Also note that you need to be connected to the internet! – rft183 Oct 23 '12 at 18:30

It looks like you need to install the kernel source. Look for linux-source in the software center. I normally install the headers as well. They'll be linux-headers-3.5.0-17-generic in the software center. Then try it again!

  • I take it that's not good :P i.imgur.com/pNYtp.png i.imgur.com/A91K5.png – me4oslav Oct 18 '12 at 22:20
  • I guess it only shows up in the Software Center after it's installed. Let's do it from the terminal :) – rft183 Oct 18 '12 at 22:23
  • In terminal do: sudo apt-get install linux-sources linux-headers-3.5.0-17-generic – rft183 Oct 18 '12 at 22:24
  • Thanks dude, that fixed it (well, I had to install download the packages from packages.ubuntu.com and then install the manually) – me4oslav Oct 19 '12 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.