The desktop does not show after I installed nvidia experimental drivers. I tried nvidia simple proprietary drivers, and they did not work either.

Here is how it looks. This is not cropped or any thing. This is how it looks, after the installation of the drivers the desktop resolution decreased from 1440x900 to 1024x768

enter image description here

The desktop only shows desh and panels when I use the open source drivers.

Is there any way to fix this so I can get better performance?

  • I have the exact same problem. Sadly, the open-source driver doesn't work really good with my graphics card. Does someone have a bugreport or extra debug information?
    – Timo
    Oct 18, 2012 at 18:17
  • for me as well open source drivers are not the best
    – Levan
    Oct 18, 2012 at 18:26
  • 2
    What a shame that I can only give this one upvote!
    – Evan Haas
    Dec 1, 2012 at 3:35

10 Answers 10


I had the same thing happen. Here is how I fixed it:

  1. Switch to a terminal Ctrl+Alt+F1.

  2. Login as your username.

  3. Install linux headers:

    sudo apt-get install linux-headers-generic
  4. Uninstall nvidia driver - this depends on which version you installed :

    sudo apt-get remove nvidia-current


    sudo apt-get remove nvidia-current-updates 


    sudo apt-get remove nvidia-experimental-304
  5. Reinstall nvidia driver

    sudo apt-get install nvidia-current-updates

    When you do this, it must say something like:

    Building initial module for 3.5.0-17-generic

    If it says

    Module build for the currently running kernel was
    skipped since the kernel source for this kernel
    does not seem to be installed.

    then the problem will not be solved. Do not believe the message. It is not asking for linux-source to be install, it does only want the headers but you must install the specific -generic headers for your kernel. Run:

    sudo apt-get install linux-headers-`uname -r`

    It will not work with just linux-headers-generic or linux-headers-3.5.0-17 (for example).

  6. If it successfully installs, restart the computer :

    sudo shutdown -r now

This should allow the kernel module to compile and install properly. It did for me!

  • I am sorry this way might work but i am really new to ubuntu so Is there an easier way to fix this, thank you for the post
    – Levan
    Oct 18, 2012 at 18:53
  • I'm pretty sure there is not. For some reason it's not downloading the linux source, and it is required in order to compile the Nvidia drivers. If you still have that proprietary driver window open, you should be able to switch back to the noveau (sp?) driver... If you do the exact commands that I put in parentheses, it should work for you. Sorry it isn't easier! :)
    – rft183
    Oct 18, 2012 at 18:56
  • 2
    I managed to changed back to open source drivers with typing this command in terminal ,,gnome-control-center" and then selecting open source driver, but compiling is too much for me :) thank you very much for your help :)
    – Levan
    Oct 18, 2012 at 18:59
  • That's no problem. I'm sure in a few days there will be a fix so that you can do it graphically. At least you can use the system in the meantime!
    – rft183
    Oct 18, 2012 at 19:03
  • 4
    There's a default keybinding for the terminal: ctrl+alt+t
    – Timo
    Oct 18, 2012 at 19:29

If desktop still don't show, it might cause from Nvidia Optimus graphic card. I have laptop with GT 650M and that's also a Optimus card. Optimus cards behaves a little differently and there is no Linux support for them by default. More info about Optimus in linux: http://ubuntuforums.org/showthread.php?t=1657660

But it's possible to get it working with Bumblebee. This is how I did it on fresh Ubuntu 12.10 installation (No nvidia drivers installed):

sudo add-apt-repository ppa:bumblebee/stable 
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get install bumblebee bumblebee-nvidia linux-headers-generic 

Then reboot or re-login.

It didn't work first when I left off that second command. Then to run something with graphic card type optirun before command. In example: optirun glxspheres or optirun ./executable-file. Good way to test the difference between integrated graphics and your graphic card is to run glxspheres with and without optirun.


This saves power when you activate your graphic card only when it's needed. I hope I helped someone, because I have spent hours to find out the problem with my graphics card (yup, I'm quite new with these Linux graphics drivers).

  • 1
    thanks, I had this same problem with the NVidia Quadro K1000M and Bumblebee fixed my problems.
    – smcg
    Jun 13, 2013 at 17:34

After meddling with this for a few evenings (disappearing unity desktop, 640x480 resolution only, weird artefacts on my screen) on my Geforce GT 630, this is what worked for me:

  1. Fresh install of Ubuntu 12.10
  2. Immediately after install, run software updater. Download & Install all updates
  3. Reboot
  4. sudo apt-get install linux-sources && sudo apt-get install linux-headers-generic (I'm not entirely sure whether/why this step is necessary, but I saw it in this thread and thought I'd give it a try)
  5. Open "Software Sources" from the Dash
  6. Click "additional drivers" tab.
  7. Activate NVIDIA binary xorg driver (proprietary, tested)
  8. Reboot

so far so good - I have the NVIDIA settings panel (without the Xconfig error message), dual monitors, and high resolution.

Special note: do NOT install the "additional drivers" package (Jockey). This package actually seems to disappear after step 2 (software updates) - the method for adding additional drivers seems to have moved to the "software sources" app.

  • 2
    Installing linux-sources probably won't have any beneficial affect. You would use it when compiling the kernel. Jockey is no longer used in 12.10; this function has been taken over by ubuntu-drivers-common Nov 23, 2012 at 7:52

I just installed Ubuntu 12.10 today, and had this issue with nvidia driver.

I tried to follow above instructions, but all these failed because of two words that are quite important: "generic" and "-17".

I eventually found that the best way of installing NVidia driver is to actually use installer privided by nvidia. So I went to:


and downloaded version for Linux-64bit (install synaptic sudo apt-get install synaptic and look in the menu Settings -> Repository -> Additional Drivers to find out the exact name of your nvidia card)

Then you run the tool and it says you need kernel headers, however read carefully because it requires "generic" headers.

You need to verify your kernel version, mine was 3.5.0-17 (this "-17" at the end matters), so in my case I did:

sudo apt-get install linux-headers-3.5.0-17-generic

(find out your kernel version by typing ina terminal uname -r)

You need to kill GUI login daemon:

killall lightdm

and after that you may run:

sudo sh NVIDIA-Linux-x86_64-310.19.run

Installer will probably tell you that Noveau kernel module is loaded and will suggest adding modprobe script. You should say Ok/Yes to all whatever it tells you and then reboot and run NVIDIA-Linux-x86_64-310.19.run again.

Not sure if other approach would work as well, but this one does for sure.

  • I also was having many issues getting any NVIDIA drivers working following other advice. I installed the 310.40 drivers using this method and finally I have it working! Mar 29, 2013 at 10:44

This also works for the Nvidia 7400 cards. But if the kernel updates you must change the install line to the latest version now it is:

sudo apt-get install linux-headers-3.5.0-18-generic

instead off:

sudo apt-get install linux-headers-3.5.0-17-generic
sudo apt-get install nvidia-current nvidia-settings
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.old
sudo nvidia-xconfig

Reboot the system!

  • E: No candidate found for nvidia-current.
    – TheEagle
    Jul 26, 2021 at 16:15

I tried almost everything, but here is the one that really worked for me:

run the following commands:

sudo add-apt-repository ppa:amith/ubuntutools
sudo apt-get update
sudo apt-get install unity-reset

then reset unity with this command:


reboot and Unity is back!! I hope it works for you.


I solved the problem tonight. I installed the latest Kernel 3.7.1 after compiling it like I always do. Then I installed the nVidia drivers from Synaptic. This caused the Unity menus to disappear like what you show in your screenshot. The solution for me is below:

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Now not only is the problem solved by you have the very latest nVidia drivers!


If your install doesn't work (initial module not building), you have to make sure you only have one set of headers installed.

dpkg --get-selections | grep linux-headers

This doesn't work

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install
linux-headers-generic               install

This works

linux-headers-3.5.0-26              install
linux-headers-3.5.0-26-generic      install

In this case, simply

apt-get remove linux-headers-generic

Now, the nvidia installer will work.


I did this:

sudo apt-get autoremove fglrx --purge

Worked great.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .