7

I've upgraded to Ubuntu 12.10 and now I can't mount any partition. I get the same error with all drives:

/usb: Adding read ACL for uid 1000 to /media/evil' failed: Operation not supported

Both of my USB drives are FAT32, one is a USB stick, the other is a GOPRO cam and both were working fine in 12.04.

1
6

In my case after upgraded to UBUNTU 12.10 my username in /media didn't exist, so I created it and problem SOLVED!

1
  • 1
    Same for me. I just executed `chown user:user /media/user' afterwards.
    – krlmlr
    Oct 24 '12 at 14:44
9

It is bad advice to use permission 777 on anything. Any user on the system gets read/write access to your files.

sudo mkdir /media/${USER}
sudo chown ${USER}.${USER} /media/${USER}
chmod 750 /media/${USER}
2
  • Shouldn't that be a ":" instead of a "." between the first and second mentioning of the username? As in "sudo chown Username:Username /media/Username".
    – Mrokii
    Oct 25 '12 at 17:15
  • When talking about another answer, please use a comment on it. Due to changes in voting, the post you are referring to is no longer above your post.
    – nanofarad
    Oct 28 '12 at 18:54
1

Also you can try to mount those drives manually, using terminal:

mount -t devicefilesystem /dev/something /media/something

for example mount -t ntfs /dev/sda2 /media/windows but before doing this, you have to create directory windows (or other, it's up to you) in /media like this mkdir /media/windows. This helped me.

0

Quick and Dirty method:
I have same problem and it seemed I solved by changing user owner and group owner of the directory: /media/<your username>

In command line type

sudo mkdir -p /media/<your username>
sudo chmod 777 /media/<your username>
sudo chown <username> /media/<your username>

Pluck out usb device put it back in and it should start working

1
  • 1
    777 is bad advise
    – k0pernikus
    Oct 28 '12 at 18:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.