2

I'm running xubuntu 12.04 on a 2007 macbook.

I'm using the laptop with external screen, keyboard and mouse. Yesterday after a dist-upgrade and after I unplugged the external keyboard I noticed that the Lapotop's keyboard was mapped to whatever (J = 1 , L = 3 , M = 0 e.t.c.) however I can login and type perfectly in the login screen and as a guest.

Any suggestions on how to get more information and/or troubleshooting are welcome.

4

This looks like your Laptop keyboard has an integrated Numpad. It is active when enabling NumLock.
Your Laptop Numpad might have small drawings of numbers on right part of your keyboard with the following mapping:
jkl -> 123
uio -> 789
m -> 0

Disabling NumLock should give back those keys their primary function.

  1. Hit Shift+NumLock several times to disable Numlock.
    You might also have a combination with the Fn keys depending on your Laptop model.

  2. If for some reason you are unable to get it done with your physical keyboard, this should help:

    1. execute onboard in a terminal. This will open an on-screen keyboard.
    2. click 123, then NumLock. After every click check if your Laptop keyboard is back to normal.

    NumLock key on the onboard keyboard (after hitting the 123 key)

Notes:

  • there is no numpad on the laptop neither exists a numlock button () – ndp Oct 18 '12 at 12:53
  • Well Ubuntu is seeing one. What about Fn keys? Is there one for NumLock? If not disable the Numlock on the external keyboard. – rosch Oct 18 '12 at 12:56
  • nope, unfortanetly macs dont have this kind of things, is there any 'detect keyboard layout and functionality' command? – ndp Oct 18 '12 at 13:10
  • So your laptop is a Mac and on the external keyboard you are unable to disble the Numlock? At least the external one should have a Numlock button. On Mac keyboards it is the "clear" button: kb.parallels.com/en/5182 – rosch Oct 18 '12 at 13:16
  • The laptop's keyboard is like this lowendmac.com/mail/mb07/art/macbook_keyboard.jpg Disabling the num pad on the external keyboard does nothing (i can still use the external keyboard numpad and the laptop's keyboard is still messed up) (btw thx for the answer :-) ) – ndp Oct 18 '12 at 13:27
2

I had this problem running Linux Mint. I plugged my external keyboard in again and pressed the numlock key to turn numlock off. Solved!

-1

I found an answer to my problems with my Samsung keypad after it had been used with an external keyboard in which it does not function well. The instructions were given at Ask Ubuntu:

  • Put off the unit with the external keyboard and restart it with the external keyboard.
  • When the laptop is in the state ready to use, from the external keyboard simultaneously hit the keys NUMLOCK and SHIFT and try to hit a key which is lock before if it is reinstated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.