3

I just installing Utorrent in ubuntu but I want to change the port number localhost:8080 to localhost:8085 because my apache geronimo server using that port number. can i change the port number? thanks.

  • 1
    Is there any config files in your $HOME ? Like a .utorrent folder ? – NorTicUs Oct 18 '12 at 10:20
  • 1
    no there. there was only Docs folder – Muhammad Sholihin Oct 18 '12 at 10:24
5

A super easy way to change the port through the simple webUI and the port change persists even after reboots and even in automatic startup :

  1. Open the utorrent webUI.

  2. Then go to Settings and select webUI option

Settings

  1. You will fing a text-box with 8080(or the current port). Change the port to whichever you desire.

enter image description here

  1. Click on Save Seetings.

enter image description here

  1. Close the WubUI, wait a few minutes and its done!

This worked for me for v3.3

2

Edit utserver.conf file located under uTorrent installation directory. If you don't find it go ahead and create one.

Add the following line to utserver.conf file

ut_webui_port: 8085

Check this link for more available settings that can be used with uTorrent utserver.conf file

Hope this helps.

  • 1
    It is not as simple as that. Modifying utserver.conf in the installation directory does not necessarily change the port on a restart of the program. – Joel G Mathew Oct 4 '15 at 2:46
  • Can you tell me the path where to create or find the utserver.conf file? – abhishah901 Dec 27 '15 at 14:59
  • I found the directory here /opt/utorrent-server-alpha-v3_3. Created the file utserver.conf. I saved and restarted the pc but it still opens the port 8080! Help! – abhishah901 Dec 27 '15 at 15:15
  • I had the same problem. Removing the *.dat files solved the problem. – Marin Bînzari May 10 '16 at 8:14
0
  • Remove the old extracted file and create new one
  • Now before starting the utserver create a utserver.conf file in the same directory and put ut_webui_port: desired_server_portinto the file, or as a one-liner:

    echo "ut_webui_port: desired_server_port" >  utserver.conf
    
  • Save the file and
  • Now start the utserver, it will work.
0

About the "utserver.conf" file, please consider :

This file is configuration setting for uTorrent for Linux. If you're making changes to an existing config file, be sure to delete or rename the settings files. They'll be recreated upon startup.

Many of these settings are only read from the configuration file when the uTorrent settings file settings.dat does not already exist in the settings directory. Once settings.dat exists, the values specified in the configuration file for these settings will be ignored, and the values stored in settings.dat will be used. For other settings, the server will load the values from the configuration file every time the program starts or receives a request to reload the configuration file.

In other words : utserver.conf must be created BEFORE the first launch of utserver, OR you must delete settings.dat to force utserver.conf to be applied.

Most important, when launching utserver, you must use argument "-configfile". Example :

 # utserver -settingspath /opt/utorrent-server-alpha-v3_3/ -configfile /opt/utorrent-server-alpha-v3_3/utserver.conf -daemon

Hope this will help :)

Sources: https://gist.github.com/drunkirishcoder/d48ddde9f55ea64b1183

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.