9

Trying to install Google Chrome on my fresh Ubuntu 12.04 install. I have run a full apt-get upgrade and apt-get update on this system before installing Chrome. I downloaded the 32-bit deb package from www.chrome.com and opened it in Ubuntu Software Center. It gets almost to the end and then throws up the following error.

Any insight?

Unpacking google-chrome-stable:i386 (from .../google-chrome-stable_current_i386.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-stable:i386:
 google-chrome-stable:i386 depends on xdg-utils (>= 1.0.2).
dpkg: error processing google-chrome-stable:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for gnome-menus ...
Processing triggers for man-db ...
  • Have you tried sudo apt-get install xdg-utils ? Then running the installer again? – Argusvision Oct 17 '12 at 18:54
  • I would change to chromium-browser since google has dropped support for 32bit chrome builds. – dgonzalez Jan 6 '17 at 17:56
4

I followed the instructions from here and finished with:

sudo apt-get -f install

I have no idea how or why, as I'm completely new to Linux, but it worked.

2

Check to make sure your OS is 32 bit. Your message looks like the one I got when I tried to download the 32 bit version on my 64 bit machine.

1

I was not able to install the google-chrome-stable-i386 via the software update. However; I was able to install in with the following line of code via the terminal:

sudo dpkg -i google-chrome-stable_current_i386.deb

so far it is working with out issue..

Oh, I have Linux Ubuntu 14.04 LTS

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.