2

I'm trying to install Epson Stylus SX420W. I have PPD file, I connect printer with USB and install it with PPD. It recognizes printer and install it but it gives this message Printer needs epson-espcr-wrapper package before printing. Install it..

What is epson-espcr-wrapper package? How can I install it?

1
sudo apt-cache search escpr

gives:

epson-escpr - transitional dummy package for epson-escpr printer driver
libescpr-dev - printer driver for Epson Inkjet - library development files
libescpr1 - printer driver for Epson Inkjet - shared library
printer-driver-escpr - printer driver for Epson Inkjet that use ESC/P-R

I suggest to install printer-driver-escpr.
epson-escpr-wrapper is a cups filter and is likely to be found in /usr/lib/cups/filter/.

If that does not work out, download and install the deb package from openprinting.org.

sudo dpkg -i epson-inkjet-printer-escpr_{version}{arch}.deb
| improve this answer | |
0

Try installing the requested package using the following command:

sudo apt-get install epson-inkjet-printer-escpr
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.