I bought this microphone from Amazon last week. It's detected just fine in 12.10. I can see it in the sound preferences. The problem is that the volume is so low as to be inaudible, even when turned up to maximum in this dialog. It is working, as I can see that the meter responds to noise, but it's just too low.

alsamixer's control is the same, so that doesn't help. I tried messing around in pulseaudio too, but to no avail.

In lsusb it's Bus 002 Device 004: ID 0556:0001 Asahi Kasei Microsystems Co., Ltd AK5370 I/F A/D Converter.

  • I should note that other microphones (namely the one built into my webcam) work just fine. – Iain Lane Oct 18 '12 at 7:46
  • Have you tested it on another machine or OS? – Anthony Oct 19 '12 at 17:45
  • @IainLane - anything in this blog about using audacity that works for you? blog.highub.com/linux/… – fossfreedom Oct 20 '12 at 10:07
  • @Anthony — yeah. I just tried it in Windows. It's just the same there actually - perhaps faulty? – Iain Lane Oct 24 '12 at 13:21
  • 1
    It's unfortunate that a faulty microphone is worth a bounty of 250 rep points. That was honestly my first thought, but didn't think that a recommendation to test the mic was worth putting it in as an answer. It's always best to test the hardware in other environments when applicable. – Anthony Oct 24 '12 at 16:56

So your microphone doesn't work?

Let's go through the troubleshooting steps to diagnose the problem.

  1. Test the microphone in another Environment.

    • If you have a dual boot setup, test the mic in the other OS that is installed.
    • Try a live disc from a different distribution.
      -- If neither of these tests result in a functional microphone it is possible that either the mic is malfunctioning, or the physical port on your machine is faulty.
  2. Test on another physical machine

    • If the mic is not functional on a different machine it is likely that the microphone is faulty.
  3. Test other microphones in your machine.

    • If a known-to-be-working microphone doesn't work, chances are that either the physical port on your machine is faulty, or there is a problem with PulseAudio / ALSA.

If after testing the physical hardware you determine that all works as expected, but you still don't have a functional microphone it might be possible that either PulseAudio or ALSA need additional configuration.

Make sure the input device you want to use is properly selected in pavucontrol. The Recording tab will show the active input device. The Input tab will allow you to select which input Port to use and to adjust the gain. Values over 100% are permitted. Additional configuration is available with the pacmd tool.

Adjustments to devices can be made with amixer from the terminal. Ensure that devices are not muted. You are able to set device volumes there as well.

  • There is also other great community provided how-to guides and forum pages that might be of assistance. Like this post at ubuntuforums. ubuntuforums.org/showthread.php?t=205449 Since the other answers were so terse, I figured it might benefit the community to have something a bit more detailed. The answer provided here is meant to be generic enough to apply to all while being detailed enough to get them on the track to success. Good luck on your journey! – Anthony Oct 24 '12 at 21:54

Here is the top rated 1 star review for your microphone.

Me and my friend both ordered the same mic from Amazon on the same day. They arrived soon after. But the one I received was a faulty one and the microphone's gain is extremely low.

My friend's mic seemed to operate fine. So we swapped the units and checked that it wasn't something to do with our computers. And that mic was still faulty. So I returned mine and got a replacement unit. But unfortunately the replacement unit I received was also faulty!

If you Google "Logitech mic gain too low", you can find a whole forum on Logitech's website where people have the issue and let me tell you, it's nothing to do with the OS as people might tell you. We have tried 2 faulty units on OS X 10.8, OS X 10.7, Win 7, Win 8 and it looks like a design issue in certain batches at least.

It looks like you got one of the faulty microphones.

  • Consider putting more effort in to an answer. Provide methods to test the hardware and additional steps to take if testing shows the hardware to be functional. Example: Test the mic in another machine. Test another mic in your machine (make sure the port works). If all test show the hardware working, adjusting the gain can be done by using pavucontrol. Additional adjustments can be made with amixer or pacmd. – Anthony Oct 24 '12 at 17:10

I have the same microphone and it's (now) working fine. On reading your post I found mine had stopped working (weird analogue noise but no signal) since upgrading to 12.04, but a restart and leaving it plugged in for boot fixed this.

Make sure you install pavucontrol if you haven't got it (I think they stopped shipping it by default a while back, but maybe this has changed). It's still the most effective way of "debugging" any Pulse-but-not-ALSA recording problems. It also allows you to turn the gain up past 100%, which is what you might need here. pavucontrol input devices

Hope that helps. It's a great mic too for the price :)

  • No, sorry, it's no good. I rebooted with it connected (and enabled!) and there's no difference. I can turn that control up to maximum — actually it's the same control as the one in the GNOME dialog — and it's still far far too quiet I'm afraid. Fortunately it turns out my new webcam also has a good enough mic built in, so this isn't the end of the world. – Iain Lane Oct 24 '12 at 13:17

I'm posting this in hopes that someone else realizes what I didn't:

This microphone has a green button on it. You need to press it to turn it on. I spent probably 30 minutes debugging the same issue in this question; I could see only a very small gain on the mic. Then I looked down, pressed the button, and smashed my head into my desk.

  • I wish that worked for me! Sadly I tried this at the time (and just did again to double check, to no avail). Thanks for posting though. I hope it helps someone else. :-) – Iain Lane Dec 17 '12 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.