Last week I've updated my hardware and after installing Ubuntu 12.04 I has some problems with the sound, there was:

1) I replaced the old mainboard with a Asus P8H77-M Pro board with onboard sound and found out that I didn't have any sound controls: system settings -> Sound did not respond. Answers to this problem were: go to the sounds settings. This doesn't work when sounds controls aren't willing to open. (would like a sollution for this)

I uninstalled PulseAudio and rebooted. Through the gnome alsamixer I could set the master output and sound is working now, although not as I would like it to work. Audio control now opens but no devices/settings can be found.

2) My second problem is the USB sound device not showing up. I've used this USB headset on my old system so I know this should be working. What are the things that I can check to figure out what the problem is? Alsa mixer is showing an USB device and output is set to max but still no sound. Pulse did recognise it was a logitech but I had no sound there as well (se first problem).

I'm a novice user.

Thanks in advance.


I have had the experience that the existing sound settings of Ubuntu (the ones that appear if you click on the sound icon next to the time) are too simplified and do not control all the options of my sound card.

For that reason, I got the suggestion to use a more advanced controller, which works with pulse. It is called PulseAudio Volume Control (or pavucontrol) and you can install it from the Software Center. You most probably have to re-install Pulse, it's the best way to get along with sound if you have latest Ubuntus.

You could also try other ubuntu packages for this purpose, such as Default Sound Card asoundconf or PulseAudio Manager paman. Unfortunately I have no experience with those myself

|improve this answer|||||
  • I tried re-installing Pulse and the Pulse Volume Control but that didn't help. The audio icon (top right hand corner) showed audio as muted and was not clickable. Also the System Settings > Sound did not respond. When clicked the sounds control does not open and just hangs. – CodeWalker Oct 15 '12 at 14:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.