This is an issue I've been facing for a long time. However I am still able to use my ubuntu via recovery mode, where I log-in to the shell, where I type startx. Sometimes when i restart, it goes in clean. But most of the time I get hung up with the splash screen.

Wondering if this is an issue with mount: heard that ubuntu will check the hdd once after every 30 mounts. I seem to notice it has not being doing that for a while.

  • Can you switch to a terminal pressing CTRA+ALT+F1 when it's hang?. I suspect more of a plymouth issue than mount problem, but it could be a couple of things. Aug 12, 2010 at 7:06
  • @javier tried that. Didn't work
    – deostroll
    Aug 12, 2010 at 9:42
  • You may want to update your question with other actions you've tried and the results.
    – moberley
    Aug 12, 2010 at 10:09
  • In the Grub menu, if you select the normal install and hit the key E you can edit it. Please edit it and remove the words splash and quiet from the line. Then hit enter to boot it. It should show more info now. Aug 12, 2010 at 11:36

3 Answers 3


Boot in recovery mode

Try pressing Esc right after you BIOS screen to access the grub menu, there you choose "Recovery mode" this will give you more debug messages. When the recovery menu appears you can "Drop to root shell prompt" and then look at the logfiles in /var/log folder, especially dmesg.0 (Kernel debug messages from last boot) this might point you in the right direction.

  • paste.ubuntu.com/479448 - this is the last 50 lines of dmesg.0
    – deostroll
    Aug 17, 2010 at 15:34
  • 1
    The problem might be in line 36, 37, 38 i would start by starting from a live-cd and choose recovery-mode, then enter a terminal and run: fsck -c -f /dev/sdb1 Looks like it was hanging for 4min 50sec, does that seem right? Aug 17, 2010 at 16:24
  • Think you've to execute what Source Lab has given a couple of times, and by default make it to substitute yes for each question it asks...
    – deostroll
    Nov 9, 2010 at 9:51

Although this is not a technically a 'solution', try booting in from a different Kernel if you have any. I also have this issue but been able to boot from a different Kernel. (Primary Kernel: 2.6.32-25-generic, Secondary: 2.6.32-21-generic -- Secondary Works!)


Glad to know I'm not the only one. I have gotten this problem a number of times too. No amount of hitting ESC key or any other key combination works. The only way is to do a hard reboot. I've always wondered about it but haven't bothered so much since it still works after the forced reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.