0

After I choose Lubuntu on my Grub nothing happens. The screen turns black, the keyboard lights up like it may be doing something, but over time nothing happens.

This started happening after I closed my laptop and opened it up again. Now Lubuntu will not boot at all.

2 Answers 2

1

This is likely because of something known as framebuffer. In order to disable it try adding the kernel parameters i915.modeset=1 or i915.modeset=0. In order to do this you'll need to restart computer, then press Shift to enter the grub menu, and when Ubuntu is highlighted press e. After seeing the line which has something like linux_gfxmode or something like that add one of those parameter to the line. Once you've done that press Ctrl+X.

0

my mobo is Intel D2500HN which has only 1 VGA port and no LVDS-1 my distro: lubuntu 18.04 my problem description: 4.15.0-20-generic: displaying FHD1920x1080 ok 4.15.0-42-generic: blank screen after a few lines appear after grub screen

~$ sudo lshw -C video *-display UNCLAIMED
description: VGA compatible controller product: Atom Processor D2xxx/N2xxx Integrated Graphics Controller

First to make sure your firmwares and module libraries are intact for i915

~$ modinfo i915 modinfo: ERROR: Module i915 not found.

======solutions===== make sure that both your "/lib/firmware/i915/" and "/lib/modules/'uname -r'/" are populated with files I lost mine due to "apt autoremove"

~$ sudo apt install --reinstall linux-modules-'uname -r' linux-modules-extra-'uname -r'

After ~$ sudo modprobe i915

~$ sudo lspci -v | grep -A 10 -i vga 00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller]) Subsystem: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller Flags: bus master, fast devsel, latency 0, IRQ 28 Memory at d0100000 (32-bit, non-prefetchable) [size=1M] I/O ports at 20d0 [size=8] [virtual] Expansion ROM at 000c0000 [disabled] [size=128K] Capabilities: Kernel driver in use: gma500 Kernel modules: gma500_gfx

and finally settle your grub:

~$ sudo /etc/default/grub

video=LVDS-1:d is disabling LVDS-1 port which some kernel version might be directing the video to that port on default despite your mobo might not have such a port available to you

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 video=LVDS-1:d"

~$ sudo update-grub

my problem solved, credit due to https://bbs.archlinux.org/viewtopic.php?id=145648 which in turn drew his solution from http://permalink.gmane.org/gmane.linux.mageia.devel/13667

I had spent many days trying to nail this issue. Hope my findings are of use to you linux supporters. Cheers

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.