I have a Dell XPS 15z laptop.

As you can see here, there are some issues with NVidia drivers. The site recommends installation of Bumblebee (instructions given in the link). I am posting it again for convenience:

$ sudo add-apt-repository ppa:bumblebee/stable
$ sudo apt-get update && sudo apt-get upgrade
$ sudo apt-get install bumblebee bumblebee-nvidia
$ sudo usermod -a -G bumblebee $USER 

After restarting the computer however, the screen resolution was stuck at 640x480 and I got the following error message as soon as I logged in:

**Could not apply the stored configuration for monitors**
none of the selected modes were compatible with the possible modes:
Trying modes for CRTC 63
CRTC 63: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 0)
CRTC 63: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 1)
Trying modes for CRTC 64
CRTC 64: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 0)
CRTC 64: trying mode 640x480@60Hz with output at 1366x768@60Hz (pass 1)

Prior to the update, the display was absolutely normal and thus there is no doubt about the cause. Albeit, there was no support for graphic drivers. In case it helps, some features of graphics drivers seem to be functional after bumblebee, ie, all features are in order except for the resolution.

And if the resolution can't be fixed, please suggest a way to retract the changes so that atleast the prior state may be reachieved.

Any help in the matter would be highly appreciated.


4 Answers 4


I have a Dell XPS 17 laptop and just had the same problem after running nvidia-xconfig and then rebooting. Got stuck with 640x480. I deleted the /etc/X11/xorg.conf file and the resolution returned to normal after rebooting again. It worked, but I'm just not sure this was right thing to do to return to a previous state..

  • 1
    Haha, worked like a charm! Great solution. Lenovo T420s Ubuntu 12.04
    – Alex
    Oct 22, 2012 at 0:43
  • 2
    I have the same problem, but my laptop does not have the file /etc/X11/xorg.conf. Any suggestions? Feb 17, 2013 at 14:05

I have been having the same issue. For some reason nvidia-current drivers are broken. But these two lines of change atleast let me revert back to proper display settings

In /etc/X11/xorg.conf, look for these two lines :

HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0

and replace them with

HorizSync 30.0 - 83.0
VertRefresh 56.0 - 75.0

that solved my problem and so it should for you as well. Maybe you would want to look into the ironhide project. Its a continuation of Bumblebee and loads of people claim its much better. Haven't tried it out meself though.

  • 2
    Is there any chance you can tell where you got these numbers from. I am a bit apprehensive of just going for this...
    – Pezzzz
    Aug 1, 2013 at 11:00
  • 1
    Awesome! works like a charm!
    – Vor
    May 6, 2014 at 14:05

For the record, I've just installed Ubuntu 12.04 on my new Dell 17R SE laptop with a discrete NVidia 650M. After installing the latest greatest NVidia drivers, (310.32,) I find myself stuck in 640-480 too, though the screen image seems to be scaled up to full height.

I tried installing Bumblebee to no avail, & will try the solutions listed here as well, (including Ironhide.) If nothing works, I will reinstall afresh & try again.

In any case, I will post results here.

***EDIT:****** The above suggestion on editing the hsync & vsyns settings in /etc/X11/xorg.conf worked for me: I once again have settings choices besides "640x480" in my Displays dialog. However, when opening the NVidia X Server settings, I get the following message:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

Will try this & post an update.


First download the driver file from Nvidia, it must be in .run format. change its name and paste it on your system desktop (the name must be shorter like 2.run). Then press alt+ctrl+T (it will pop up a terminal) and place the following command:

echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
update-initramfs -u

Then restart and try not to login into the GUI. You will have to press alt+ctrl+f1 repeatedly. After entering in console mode type the location of you driver file. If file is on the desktop then type:

cd ~/Desktop

After this type the name of the file like this:


(2.run is the name of the file which I downloaded from Nvidia and renamed it for ease of access). Install the driver(it is easy). Now reboot.

When you login to your system after installation the resolution will be changed and it will create a problem.

The solution is to open the console by pressing alt+ctrl+T and typing:

gedit /etc/X11/xorg.conf 

(this is the xorg configuration file and we are going to edit it). Search for the monitor section. Under this section we will see: HorizSync 28.0-33.0 and VertRefresh 43.0-72.0. Replace them with HorizSync 30.0-83.0 and VertRefresh 56.0-75.0.

Now reboot your system and you are done.

  • Welcome to AskUbuntu. Please avoid using slang in your posts. Jan 29, 2014 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.