This is what the lspci -v command shows in the VGA compatible controller section:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])
Subsystem: Dell Device 048e
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at f0200000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 18d0 [size=8]
Memory at d0000000 (32-bit, prefetchable) [size=256M]
Memory at f0000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

i915 is only compatible with OpenGL 1.4 and cannot use shaders and I'd like to use some Open GL 2.0 functionalities.

Is it possible to update the drivers or is my hardware limited to OpenGL 1.4 ?

  • Have you tried running jockey-gtk? This searches for updated or "additional" drivers. (Just trying to check the simple things first.) – Argusvision Oct 14 '12 at 14:44
  • I just tried, jockey-gtk doesn't find anything. – madmaxpt Oct 14 '12 at 14:51
  • You could also open synaptic and search i915. There is an xserver-xorg-intel package that may work for you. I have no way of testing it on my hardware. – Argusvision Oct 14 '12 at 15:01
  • To answer the secondary question, "Is it possible to update (to use Open GL 2.0)? This article indicates yes. phoronix.com/scan.php?page=news_item&px=OTk4Mg – Argusvision Oct 14 '12 at 15:07

Intel has not additional drivers (restricted drivers) available for Linux. The drivers are all open source.

If you want to update the driver for Intel graphics card you can add a PPA where the newest drivers included and update from there.

Example . Ubuntu X - Team

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

If you want to revert back (undo)

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade
  • I did what you told me, it updated the drivers, but the glxinfo | grep version command still indicates "OpenGL version string: 1.4 Mesa 8.0.2". Any idea on how to tell it to use OpenGL 2 ? – madmaxpt Oct 14 '12 at 15:32
  • 1
    If your graphics card (hardware) not supporting OpenGL 2.0 , then the driver cannot do much (I think). Take a look here and according to your graphics card model , see if supports OpenGL 2.0 – NickTux Oct 15 '12 at 7:29
  • The card DOES support 2.0: phoronix.com/scan.php?page=news_item&px=OTk4Mg – Milan Babuškov Oct 21 '14 at 22:33
  • The link is dead. – kenorb May 13 '18 at 19:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.