15

I have just bought a shiny new Canon MG6250 multifunction printer/scanner and connected it via LAN. Installing the printing side of things was a breeze, however, I cannot work out how to set up scanning.

I installed the MG6200 series ScanGear MP driver from Canon's site but when I open GIMP or Simple Scan, they say there is no scanner detected. Using GIMP's 'update scanner list' button to search for the scanner does not find it.

How do I tell Ubuntu, GIMP or Simple Scan to look on the network for the scanner? Is there another utility especially for this?

  • Found a few pages via Googling talking about xsane and configuring it. Most of them talk about scanning using a USB connected scanner. I tried a few of the outlined tweeks, but none have worked so far. – Andrew Oct 21 '12 at 4:29
  • Did you try the command line tool that comes with the ScanGear driver, scangearmp? That found it for me. – Noyo Sep 8 '13 at 10:06
20

Just got this going today. This is how I got it working over wireless network, running Xubuntu 12.10 64-bit. (No Canon drivers were needed).

After installing xsane:

  • The sane man pages refer to "backendname" a lot. http://www.sane-project.org/sane-mfgs.html gives the backend name for the 6250 as "pixma"

  • man sane-pixma (seems to be a man entry for each backend) tells you that network scanners should normally be detected, but if not, add them directly to /etc/sane.d/pixma.conf

  • Edit that file and add a line of the format:

    bjnp://<ip_address>

  • IP address can be retrieved from the printer settings, or from the options in the printer itself.

  • After adding an entry for the printer, save pixma.conf

  • Now edit /etc/default/saned and set RUN=yes

  • Then: service saned start

  • Run xsane

Now xsane should discover the scanner, and instead of saying "no devices found" and dying, it should run up (brings up about 4 windows). All the default settings seem to work — just press "Scan".

  • Thankyou for that concise explanation. Works a treat now!! – Andrew Oct 18 '13 at 10:22
  • Good tip! My scanner isn't on the officially supported list. It didn't respond over the network but worked fine via USB from xsane. – Stephen Niedzielski Apr 14 '15 at 19:46
  • This is exactly how I resolved an issue with my Ubuntu 15.04, Canon PIXMA MX870 (a network multi-use device connected via WiFi) and Simple Scan. Now everything works very well. Thanks for a great tip! – madjoe Oct 23 '15 at 19:19
  • Note you have to do sudo service saned start or the service won't actually start. Use sudo service saned status to confirm it has started. You should see: saned is running. – snark Dec 24 '15 at 17:11
  • @snark: yes, all of the commands above (editing in /etc/...) have to be run as root. I've found most instructions leave it out, I guess to not clog up every command, so I followed that trend. – Ash Dec 24 '15 at 22:42
2

I have an epson printer/scanner and had to add the IP address to /etc/sane.d/epson2.conf like this:

net 10.0.5.125

I also commented out the net autodiscovery line.

  • 1
    Thanks! Less complicated than the accepted answer and worked for me right away. – gavsiu Oct 9 '18 at 22:16
  • 1
    Same here, worked perfectly for my EPSON XP-950. It worked only with the USB before changing net autodiscovery to the real IP of the scanner. – wotter Feb 8 at 17:27
1

I found that adding the subnet IP addresses to this file worked when nothing else did: /etc/sane.d/saned.conf

To get the subnet, look at your output from the ifconfig command. Find a line that looks like this: inet addr:192.168.1.4 Bcast:192.168.1.255 Mask:255.255.255.0

From this output, I learned that my wireless router subnet is 192.168.1, and then searched for the printer (wireless router and printer must be powered on and operating) using this command: sudo nmap -sP 192.168.1.0/24

Nmap scan report for 192.168.1.6 Host is up (0.011s latency). MAC Address: XX:Xx:XX:XX:XX:XX (Canon)

From above, 192.168.1.6 is the IP address for my Canon printer/scanner on my LAN.

Therefore, I added this entry to /etc/sane.d/saned.conf: 192.168.1.0/24

xsane could then see my scanner.

  • On Ubuntu 16.04 (2018), this worked for me. Something must have happened to make saned stop scanning the proper network. – danShumway May 5 '18 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.