Recently, my internet connection over wireless has become unreliable, on both a Dell laptop running Ubuntu 10.04 as well as my Desktop running Ubuntu 10.10 . The problem does not seem to occur on a laptop running Windows Vista. The problem does not seem to occur on my Openmoko Freerunner ( running Android 1.5 ), though I hardly ever use this device to connect over WLAN, so the problem may have just slipped by. This problem does not seem to appear when I boot into Ubuntu 9.10 from a live CD ( more precisely, I was able to ping fu-berlin.de for an hour without any packet loss ). Under Ubuntu 10.10, I am experiencing about 33% packet loss.

On my main Ubuntu Desktop, I have tried the following wireless devices:

  • a Longshine PCI card ( an old device with an RTL8180L chip )
  • a D-Link DWL-510 PCI card ( this device threw warnings in dmesg )
  • a USB device from MSI ( US54EX ).

Usually my wireless network shows up in the network manager with a normal signal strength, even when the connection speed is slow ( which happens often ) or the connection gets reset ( asking me to click connect to re-authenticate my wireless connection ).

I have observed this problem with a Netgear KWGR614 Router ( with the manufacturers firmware ), as well as with a TP-LINK TL-WR741ND router running OpenWrt.

Taking a look at my routers logs, I find many instances of the following line:

Tuesday,04 Jan 2011 03:53:01 [TCP SYN Flood][Deny access policy matched, dropping packet]

I know that the Netgear router is susceptible to denial of service attacks, as I have previously been able to disrupt its operation by putting an nmap scan into a while loop. I use WEP on the Netgear router and WPA on the TP-LINK to encrypt the wireless connections.

I seemed to have been able to circumvent the problem for a while ( at least on my main machine running 10.10 ) by putting

iwconfig wlan1 power off

into my /etc/rc.local. ( Thereby turning power management off on my wireless device .) Further testing has shown that this reduces packet loss to about 5%.

Strangely though, power management is on by default in 9.10 ( where the connection worked fine ), and it is already turned off on the laptop running 10.04 ( where I get a bad connection sometimes ).

Ubuntu support suggested I try the backported wireless drivers, which seems to have gotten rid of the packet loss phenomenon, but pages are still loading very slowly, including the configuration page for my wireless router.

I have now filed a bug on launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/704777

  • If you need more details, please post a comment ( not an answer ) and I will edit those details into my question. Thanks. – gabkdlly Jan 4 '11 at 11:20

This may be caused if there are drivers that are available but are not activated. Go to System-Preferences-Additional Drivers. See if there are any drivers available for you to install.

  • Thanks, but there are no proprietary drivers available for the systems in question. – gabkdlly Jan 5 '11 at 6:37
  • 1
    OK, check the MD5 check sum for the ubuntu iso you downloaded. It may be though, that your router is set up wrong. – user8339 Jan 13 '11 at 16:54
  • I always check the iso, and the CD integrity via the boot option, before installing. – gabkdlly Jan 19 '11 at 7:01

I seem to be able to circumvent this problem (mostly) by using the Windows drivers for my hardware. This is done with ndiswrapper.


There is a helpful graphical user interface for ndiswrapper in the repositories.

sudo apt-get install ndisgtk

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.