When I first installed Ubuntu 12.04 LTS 32.bit from a Live-CD without internet connection and any updates the snapping feature worked fine for windows of all applications. However, after some updates and installations it stopped working. I can no longer drag a window to the edge of the screen and have it resized. Thinking the problem is from my lack of experience I did a clean install of Ubuntu 12.04 again with internet connection; however, the problem still persists and I am fed up with this. Do you have any suggestions for remedy? Thanks in advance.

P.S: The feature when working properly was just like that in Windows 7. I am a new user BTW so I might be skipping some important details, and I would be glad if you can remind me of them.


First you should make sure Compiz is running. In a terminal type:

ps -A | grep compiz

If there is no output, you have a bigger problem and you need to properly configure your graphics card. Try running jockey in dash and installing proprietary drivers if you need them. If you are using a laptop with Nvidia Optimus card, look into the bumblebee project: http://bumblebee-project.org/

Further graphics card troubleshooting is beyond the scope of this answer.

If Compiz is running and you still don't get the snap feature: Install Compiz Configuration Settings Manager (ccsm) either through the software center or by:

sudo apt-get install compizconfig-settings-manager

Open up ccsm (you can just type it in the dash).

Go to the Window Management Section and make sure that Grid is checked: enter image description here

If you open Grid, you can choose the Edges Tab and alter the settings there: enter image description here

  • Unfortunately this did not work.
    – Vesnog
    Oct 13 '12 at 14:29
  • Can you confirm that you are in Unity and not Unity 2D? One way to check is to go to a terminal and type ps -A | grep compiz. If compiz is not running then this feature won't work and more likely you are having graphic card setup issues
    – Ian B.
    Oct 13 '12 at 14:37
  • That does not yield any output, how can I configure my graphics card, Nvidia GT540M, then?
    – Vesnog
    Oct 13 '12 at 14:51
  • Edited the answer to give some hints, but graphic card problems can be tricky and I'm no expert
    – Ian B.
    Oct 13 '12 at 14:58
  • Hmm still not working.
    – Vesnog
    Oct 13 '12 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.