Update: Though it's not fully clear to me why this Q should be off-topic and I have doubts that a bug report will help, I filed a bug report at https://bugs.launchpad.net/unity/+bug/1067349 Please vote for it if you are affected, too!

I have a nice Lenovo Thinkpad Edge 11 AMD Neo II with a ATI Radeon 4225 integrated graphics device. In my perception this is already a not-so-lowspeced device, but still a netbook.

Up to Ubuntu 12.04 precise pangolin I preferred Unity2D over Unity mainly because it did perform much better than Unity and moreover I was able to achieve 5-6h with one battery charge. The typical load of an idling desktop settled around 0.00 to 0.02.

Yesterday I tried the new Beta 2 of Ubuntu Quantal Quetzal: This does no longer offer a Unity2D version. The performance itself has definitely improved over Unity in precise, but nevertheless I do experience now a minimum load of 0.24 to 0.36 while completely idling. According to top this is mainly due to compiz eating about 3-6% CPU all the time.

In comparison to my Unity2D experience, quantal is more sluggish, eats much faster my battery and produces significant more fan noise. I already tried a few tweaks like static blurring, fast texture renderer or choosing alternate window manager.

Are there ways which enable me to continue to use Ubuntu/Unity on my device without major loss of functionality, performance and battery life?

closed as off topic by Mitch, Tom Brossman, user61928, mikewhatever, Amith KK Oct 13 '12 at 8:23

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

  • This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. – Jorge Castro Oct 12 '12 at 16:56
  • You should probably just file bug reports on this. – Jorge Castro Oct 12 '12 at 16:56
  • Or maybe perhaps documenting the fixes you mention as the start of an answer that people can add to? – Jorge Castro Oct 12 '12 at 17:05
  • Thanks for your fast feedback, Jorge! Regarding the fixes I tried (mainly found on askubuntu.com): I tried a combination of 1) using static/none blurring via Ubuntu Tweak 2) Using CCSM set texture renderer quality to low, disable vsync wait and refresh rate detecion 3) using mutter window manager instead of compiz. Ok I'll try to file a bug report and see if this may help. – Ben Tebulin Oct 12 '12 at 17:22