I've seen elsewhere that scrolling via the mouse wheel (and other mousy events) can be enabled for tmux.. can this feature also be enabled in byobu (over tmux) and how?

4 Answers 4


If you still have this problem,

Try ALT + F12

In my case, this enables mouse scrolling on byobu

  • 1
    It can help the poster if you indicate where you found this shortcut Commented Jun 30, 2014 at 5:48
  • There's Help menu in configuration. You can find it by running byobu-config on the terminal or simply press Shift+F1
    – RNA
    Commented Jul 1, 2014 at 1:52
  • 6
    It's interesting that turning mouse support off causes the scrolling to work. Anyone why that is? edit: And I see that this stops me from selecting text with my mouse... :(
    – alecbz
    Commented Nov 11, 2014 at 23:05
  • 2
    @alecb, it seems that when in the "mouse off" mode, you can still select text with the mouse by holding shift. edit: oh, just noticed that this is also mentioned in EvanLanglois's answer
    – yoniLavi
    Commented Apr 24, 2015 at 11:51

Yes, this is possible. You just have to enter scrollback mode first.

Simply press F7, and then use your mouse scroll wheel. Finally, press ESC to exit scrollback mode.

It appears that some terminals won't allow you to scroll using your mouse still. For Gnome Terminal, untick the Scroll on keystroke option in the profile preferences (tab Scrolling).

  • 11
    Hmm, that doesn't seem to work for me. Instead I get the whole terminal scrolling, making the byobu session disappear off the screen? Am I missing some additional setting somewhere? (Using gnome-terminal to ssh into server where byobu session is running)
    – Ashimema
    Commented Oct 17, 2012 at 9:16
  • 4
    What if you press alt-pageup, and then try using the scroll wheel...does that work? Commented Oct 22, 2012 at 14:38
  • 2
    Confirmed working with Konsole. Confirmed ineffective in Gnome Terminal by default - had to untick Scroll on keystroke option in profile preferences.
    – gertvdijk
    Commented Jan 5, 2013 at 21:21
  • 6
    @DustinKirkland also I notice that I need to press Enter to exit the mode, not Esc as you indicate. Has this changed recently perhaps?
    – Karthik T
    Commented Aug 3, 2013 at 3:17
  • 5
    FYI, this does not work for me in gnome-terminal, even after disabling "Scroll on keystroke".
    – alecbz
    Commented Nov 11, 2014 at 23:14

Add below options to ~/.byobu/.tmux.conf:

set -g mouse on

detail here

  • 2
    It really works fine.
    – rashok
    Commented Jan 12, 2020 at 14:14
  • 3
    This is the real answer. This one deserves to get to #1, not #2!
    – EnzoR
    Commented Nov 3, 2020 at 8:13
  • 2
    This one should be the accepted answer.
    – Tran Chien
    Commented Apr 2, 2023 at 2:29
  • Really nice and does answer the question. However, now I find it difficult to mark and copy text from the scrolled console. Is there a set -g something_awesome on for that, too? Commented Jun 4 at 9:45
  • 1
    @Markus-Hermann hold the shift key down while selecting. Or depending on OS - look here: unix.stackexchange.com/questions/332419/…
    – ostergaard
    Commented Jun 5 at 9:44

If you just want scrollback and you don't want to engage the tmux "mouse-mode" (which will interfere with your ability to cut-n-paste with the mouse) just add the following to $HOME/.byobu/.tmux.conf

set -g terminal-overrides 'xterm*:smcup@:rmcup@'

Now your terminal's scrollback works normally and you don't need to hit any special keys to engage the mouse. The drawback is that the terminal only knows about a single screen. You'll still need to use "mouse mouse" to scroll a screen other than the most recent (such as to get to a long-scrolling log buffer), but if you just want to scroll up to see what just scrolled off your screen, this will fix it! It doesn't know about split screens either. BTW, the "mouse mode" can be set automatically in your config files. You paste with your command key (usually Ctrl-A) followed by the ] key. The mouse selection is cut automatically in mouse mode, but you'll have to get out of mouse mode or hold down Shift to get the usual clipboard behavior that allows you to paste into another GUI app.

Recommendation: Since byobu already uses multiple terminal sessions inside itself, you don't need to use it with multiple terminals. So, instead of having a hot-key that opens a new terminal, I assign my "open terminal" hot-key to tilda. Tilda drops-down from whatever workspace you are currently using (shows on all workspaces) and it stays running so it is always available. This works nicely with byobu because I now have 1 place for all my shell sessions (you can set tilda to run byobu instead of a normal shell and re-run it if you accidently exit your shell). Further, your terminal sessions out-last your GUI because you are using byobu. I log into my system with ssh and automatically get my byobu session (great to monitor compiles, etc) and the byobu virtual window resizes to my cell phone screen. When I reorient the phone, the byobu window on my desktop screen changes with the phone orientation - MAGIC! Very impressive to Windows users.

Next is to use enlightenment's terminal hacks to get a notification (from the GUI) when a terminal job finishes, but dbus permissions makes that iffy. If anyone gets this working with byobu please let me know!

  • 1
    Strange thing happened. Adding the line you told me to made it work fine on the first day but then I couldn't scroll on Byobu at all. With the mouse wheel or using Alt + PageUp. Do you know what happened?
    – azizbro
    Commented Mar 17, 2020 at 23:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .