7

I'm trying to mount a folder over ssh using sshfs. Evertime I do so I get the error

No such file or directory

My terminal:

user@computer:~$ sshfs admin@server.com:/volume1/somedir ~/mnt/somedir
admin@server.com's password: 
admin@server.com:/volume1/somedir: No such file or directory

It returns the directory listing, as expected if I try:

ssh admin@server.com ls /volume1/somedir

This is Ubuntu 12.04 connecting to a Synology NAS with DS4.1

What am I doing wrong here?

1
14

So aparently when connecting to sftp on a Synology, / is the list of shares. So I just have to do:

sshfs admin@server.com:/somedir ~/mnt/somedir
1
  • Same problem with a Synology server. Your solution worked for me. Thanks! – Gonzalo Cao Feb 1 '17 at 14:25
3

try

sshfs admin@server.com:/remotedir ~/mnt/localdir

where remotedir is dir you normally specify after volume1

or

sshfs admin@server.com:/ ~/mnt/localdir
0

I had the same error on connecting to a VM in a Debian xen host where I have forwarded every VM ssh port to another port.

All paths were correct, when testing with ssh admin@server.com ls. In the end, I noticed, that I mixed up the ports, because I had set a rule to use a certain port in my

~/.ssh/config

that was not used when trying via sshfs

so better add the port to both commands, when testing with

ssh -p<someport> admin@server.com ls /volume1/somedir
sshfs -p<someport> admin@server.com:/volume1/somedir ~/mnt/somedir

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.