76

I accidentally unchecked View -> Show Menubar which hides the menubar for gnome-terminal, and there doesn't appear to be a keyboard shortcut to show the menubar again.

alt text

How can I make gnome-terminal show the menubar again?

  • I wonder what the purpose of hiding that menubar in first place is. – neverMind9 Dec 13 '18 at 13:41
  • @neverMind9 Having a cleaner interface; why would you bloat your screen with stuff you never use? – destoryer Jan 31 at 12:36
  • @Destroyer I see. But that stuff does not bother me personally. – neverMind9 Jan 31 at 15:15
111

Right click anywhere inside the terminal, and you'll get a similar pop up menu that lets you reenable it.

alt text

  • and... once the menu appears, go into Edit->Profile Preferences->General and click "Show menubar by default in new windows". THis applies to at least GNOME Terminal 2.31.3 – Robert Lugg Nov 9 '18 at 21:30
  • it does not work in tmux. I need to open new tab/window and then context menu works. – rofrol Feb 20 at 22:07
17

You can also make it via terminal command line:

gnome-terminal  --show-menubar

If you read the man gnome-terminal you can find this:

  --show-menubar
                 Turn  on  the menu bar for the last-specified window; applies
                 to only one window; can be specified once for each window you
                 create from the command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.