I'm using the most up-to-date version of firefox and flash player. When I go on 4oD and press play I used to get the loading screen showing forever with nothing playing. I then had a search and someone suggested to turn off Ad-Block. So I did and it plays the advertisements. Once the last ad has played it does nothing.

Has anyone else got this problem? Has anyone managed to fix it?

Any help would be appreciated.



I found the solution. The same encryption issue was preventing playback on an Irish video on demand service.

Close all browser windows and then:

  1. Remove the adobe cache:

    rm ~/.adobe -rf
  2. Install hal & hal-info:

    sudo apt-get install hal hal-info
  3. Reinstall adobe player:

    sudo apt-get install flashplugin-installer --reinstall

Credit to TokyoCrusaders92 on this thread.

  • I didn't have to reinstall Flash. Very useful answer, thank you. – Andrew Aylett Sep 28 '13 at 20:53
  • 4
    For anyone trying this in Ubuntu 13.10 and getting the error message E: Package 'hal' has no installation candidate: there's a solution here: omgubuntu.co.uk/2013/10/… – Adina G Dec 24 '13 at 20:59

I had this exact same problem, starting about 2 weeks ago, on both my linux (lubuntu) machines. My girlfriend's Windows laptop was fine though. I tried disabling adblock, reinstalling flash, reinstalling firefox and various other things. Then I noticed that I was signed in to 4od. I don't remember registering, but perhaps I did. I signed out, and then registered again. It all works fine now. I can use Adblock without problems. I don't know if my registration was funny, or whether a lubuntu or firefox update caused it. It occurred to me that 4od might recognise and block users using Adblock, and my new registration solved this. I don't know, but it worked! I don't think you need to register at all to view things less than 30 days old.

  • I'm on Ubuntu 16.04, latest updates, chrome doesn't work, firefox doesn't work, opera doesn't work. Flash is working on other sites. No adblock or other blocking extensions enabled. Registered and signed in. Black screen, just seems to buffer and do nothing. – Jakke Jul 10 '16 at 14:32


As the screenshot shows - running an ondemand channel4 programme within firefox and ubuntu (unity).

So how did I do this ... well I used Wine (so please don't hate me!)

This is the recipe for this if you want to try.

  • install Wine
  • install firefox using winetricks
  • manually download flash from Adobe using your normal Ubuntu browser
  • install flash using wine.
  • launch firefox version of wine and enjoy.

In experimenting I found using the latest Wine (wine 1.7) worked much better than the standard wine 1.6 that is available in the repositories - especially when launching Flash content in fullscreen mode.

The windows firefox display is a bit glitchy - but the import part - the programmes appear to run just fine.


  1. Install wine 1.7
sudo add-apt-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends wine-staging
sudo apt-get install wine-staging-compat winetricks
  1. Install firefox using winetricks
winetricks firefox
  1. Manually download flash

Go to the Adobe website using your Ubuntu browser and download the Windows 7 NPAPI version of flash

  1. Install flash
cd Downloads
wine install_flash_player.exe
  1. Launch the windows version of firefox
wine start c:\run-firefox.bat

Note - for some reason the windows version of firefox seems to use the same profile as the Ubuntu firefox - so if you are using Adblock software you'll need to disable this in ubuntu. Shutdown firefox in both Windows and Ubuntu and start Windows firefox only.

  • Thanks for the answer @fossfreedom. I appreciate your time and cleverness, and hey, it works! But Channel4 - what are you playing at that this hugely complex procedure is necessary! – artfulrobot Nov 19 '15 at 18:49
  • Tired of this... channel 4 doesn't appreciate my watching their commercials, well I'm not going to go the extra mile for it :p They need to sort things out, not me. But it's a clever solution, thanks for sharing. – Jakke Jul 10 '16 at 14:34

New Flash versions are not supported for most browsers in Linux. You can use Chromium for the newest version (Chromium developers include flash in browser).

  • 2
    Actually, Chromium does not include Flash in the browser, but Chrome does. – Flimm Apr 27 '13 at 14:20
  • And chrome doesn't connect to play either... just keeps showing a black screen that appears to be buffering – Jakke Jul 10 '16 at 14:30

The problem seems to affect NEW content on 4OD - ie older content still works as before. There seems to be an update to the encoding/DRM used for new content which doesn't work on the Linux flash player. The only solution for now, as has been suggested, is to use the YouTube channel instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.