8

I'm using Cinnamon as my desktop environment, which is based on GNOME 3.

I've added two network printers, but I want to give them better names such as "Colour" and "Black-and-White".

The name field of the printer in the Printing dialog box appears to be editable but every time I change it, it reverts back to the original name.

How can I rename my printers?

5
  • 1
    You can try localhost:631 from your browser. If the printer server is CUPS based, you can access many options from there. Not sure about changing the name though.
    – elomage
    Oct 11, 2012 at 6:26
  • 1
    Oh and guess what, I got an answer that solved my problem, and may even help other users...
    – tdc
    Oct 12, 2012 at 6:38
  • 1
    Yeah. Why not test it on your system and just suggest that the question be reframed as a generic *buntu issue? Or point to a better question if there is one. Closing it is not helpful
    – nealmcb
    Jul 29, 2016 at 16:32
  • 1
    This question is closed, but I have found a way that does not require installing a new package: (1) stop the CUPS service, (2) edit /etc/cups/printers.conf, rename the <Printer PRINTER_NAME_HERE> line, (3) restart CUPS. May 15, 2017 at 13:37
  • 1
    I'm not sure why this is still closed; this is no longer offtopic
    – Thomas Ward
    Sep 11, 2017 at 22:40

3 Answers 3

8

I've had a lot of issues setting up networked printers in GNOME. The only way I found to get everything set up was by installing the package system-config-printer-gnome and then running the command system-config-printer. From here I'm able to do some advanced printer setup as well as rename my printers (just checked it ;)

1
  • On the Arch Linux the package is called system-config-printer (AUR). Right click on printer -> rename does not work (at least on Arch Linux). Only changing description in Printer Properties works. Sep 1, 2018 at 7:46
6

There's a way to edit the printer names without installing any new packages:

  • Stop the CUPS service (sudo service cups stop)
  • Open /etc/cups/printers.conf (backup the file first!)
  • Find the <Printer PRINTER_NAME_HERE> line
  • Change PRINTER_NAME_HERE to whatever name you want
  • Restart CUPS (sudo service cups start)
3
  • This is the only answer that worked for me. The answer from Chuck R did not work for me. Sep 1, 2018 at 7:51
  • After that my printer disappeared. Be careful.
    – lucidyan
    Dec 2, 2019 at 17:50
  • @lucidian I've added a backup step. Dec 2, 2019 at 17:56
0

This might not apply to Cinammon, but it does apply to GNOME 3, so it answers the titular question.

  • Open the Activities overview and start typing Printers.
  • Click Printers to open the panel.
  • Click the Unlock button in the top-right corner and enter your password.
  • Click the name of your printer, and start typing a new name for the printer.
  • Press Enter to save your changes.

(Source: https://help.gnome.org/users/gnome-help/stable/printing-name-location.html.en.)

Emphasis added. At time of writing, on at least some versions of GNOME 3, there is no UI indication, until you click the name of the printer, that it is in fact editable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.