I've installed Ubuntu Server Edition and setup open ssh,samba and lamp on my home desktop just to work on LAN. I also want setup a GUI on it for daily use.

I've already performed the following

sudo apt-get install gnome-session-fallback
sudo apt-get install lightdm-gtk-greeter
sudo apt-get install xinit

I don't want to install Unity or the Gnome3 Shell on my system. Also I haven't found instructions to installing gnome-classic on a server edition(although it shouldn't make a difference).How do I get it to work?

  • note that running a gui on a server is discouraged. there's a reason it comes without one. – strugee Jun 21 '13 at 7:24
  • also please be aware that while a lot of people think fallback mode is there to placate previous GNOME 2 users, it isn't. it's deprecated and has been dropped from GNOME 3.8 which means that when you eventually upgrade to something equal to or greater than 13.10 (Saucy), fallback mode won't be available anymore. – strugee Jun 21 '13 at 7:28
  • also try sudo service lightdm restart. see what the output is. if it says service not found or something, try sudo apt-get install lightdm – strugee Jun 21 '13 at 7:30
  • I did mention that this server was for light usage on my home network(LAN). I'll try the above the next time I install server edition. Currently using mint on that system. Thanks for the help! – varunyellina Jun 21 '13 at 14:09
  • yeah! you may want to look into MATE. it's a fork of GNOME 2 and is maintained, although it is still in the process of migrating away from deprecated technologies. – strugee Jun 22 '13 at 4:10

Warning : Untested since I already have gnome-3

To install ubuntu classic,

sudo apt-get install gnome-panel

as instructed in this link

  • to install fallback mode, you install gnome-session-fallback. not gnome-panel. – strugee Jun 21 '13 at 7:26
  apt-get install gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal

and then use this xstartup

    nano .vnc/xstartup

then add this in xstartup


    [ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
    [ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
    xsetroot -solid grey
    vncconfig -iconic &

   gnome-panel &
   gnome-settings-daemon &
   metacity &
   nautilus &
   gnome-terminal &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.