124

I have a problem with my virtualbox on ubuntu 12.04, I can't add a host only adapter, the message is "no host only network adapter selected" I can't select anything

enter image description here

can anyone solve this problem??

  • 1
    Can you attach it to eth0? – Takkat Oct 10 '12 at 7:08
  • yes I can. but with bridge not with host only – Ujang Karnadi Oct 11 '12 at 0:08
181

Probably, the virtual host-only network wasn't set up yet. Here's is how you can fix this:

  1. From the main menu, select File > Preferences (Ctrl+G) - NOT the settings of a single vm
  2. Select Network in the list on the left
  3. You should see an empty white box with "Host-only Networks" at the top. On the right, there are three buttons to manage them. Click the topmost one (with a green plus symbol). A new Host-only network will be created and added to the list.

screenshoot

Normally, the settings of the new network will be ok, but for completeness, I give the default values here. You can access the settings for the host-only network through the screwdriver button on the right.

ss2

  • Adapter:
    • IPv4 address: 192.168.56.1
    • IPv4 Network Mask: 255.255.255.0
  • DHCP server:
    • Enable server: checked
    • Server Address: 192.168.56.100
    • Server Mask: 255.255.255.0
    • Lower Address Bound: 192.168.56.101
    • Upper Address Bound: 192.168.56.254

You can change these settings to your liking, as long as they're consistent.

| improve this answer | |
  • 1
    thanks you,,, you have solved my problem . . . . usually I use virtual box in windows,, but now I have to use it on linux. . . . . . I'ts really different. . . . – Ujang Karnadi Oct 10 '12 at 23:49
  • You are life saver – Pavan Jadda Oct 3 '17 at 16:39
  • 44
    In 2018, you have to go to File -> Host Network Manager. – Theodore R. Smith Mar 12 '18 at 15:30
  • 3
    @TheodoreR.Smith can you make that an answer. Or update this answer please. Thanks!! – Bahrom Apr 11 '18 at 1:21
  • 4
    In 2019, you have to go to File -> Host Network Manager – Lorenzo Lerate Jan 21 '19 at 11:22
23

I installed virtual box recently and its different,

After Virtual Box is open, click on File>Host Network Manager>Add. This will add the 192.168.56.1/24 IP as shown above.

Now you can see vboxnet0 in the "Name" dropdown in the VM.

| improve this answer | |
  • yep, you are right, in newer versions the host networks has desappeared from the usual Network preferences – Antonio Jun 13 '18 at 9:31
  • Thank you. An extra note for others: This solution works for the following specs: VirtualBox v.6 , Ubuntu 16.04 , Catalina MacOS (specifically for OpenDayLight if you want to connect to mininet VM) . – McLan Jul 29 at 1:43
  • Thank you for this information. I just did a fresh reinstall of my Host OS and suddenly found this feature of VB6 inexplicably no longer working. It's frustrating when older tutorials point to a tab that's no longer there. – Myke Carter Sep 8 at 20:10
  • Thank you very much! Worked straight forward – Henning Outspoken Oct 12 at 7:53
14

For those, who are in trouble finding "Host-only Networks" tab in File->Preferences->Network.

After the version VirtualBox 5.2.0, there are some changes with the location of "Host-only Networks" tab.

This tool is moved on the main UI toolbar, specifically the Global Tools split button on the right.

Alternatively, you can access it via Ctrl+W, or File->Host Network Manager menu.

Source: https://forums.virtualbox.org/viewtopic.php?f=8&t=85464

| improve this answer | |
2

In 2020, a few changes.

  1. From the main menu select file

enter image description here

  1. Select Host Network Manager

enter image description here

  1. Select create

enter image description here

This would create the settings of the new network, check the "Enable DHCP Server". Now go back to network settings it should see the name of the newly created network when you select Host-only Adapter.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.