It's a long post but nearly covers all my experiments and changes I did to my NM. Hope the information is complete and if there are still question, more information can be provided.

I've a ZTE AC2726 USB Modem (CDMA modem) which worked fine in Ubuntu 10.04 /11.10. I recently switched to 12.04.1 (precise pangolin) All 32-bit. after the switch the first issue I faced was to connect to internet using my USB modem (ISP: Reliance Brand: Netconnect).

Tried to run the drivers provided by Reliance but they are old and won't support Kernel 2.6.30 above. since the code was not downloaded with ISO image (of 12.04) i couldn't compile the files provided in such driver.

lsusb does detect it as Modem with output similar to 19d2:fff1 ZTE CDMA technologies inc. (or similar as i didn't note it down) If it is detected as USB storage it shows 19d2:fff5 (as per few online forums, i may be wrong here).

I used the network Manager and configured the modem to dial #777 (default) and the ISP provided username:password combination. It tries to connect to internet (3-4 times automatically)but fails to get online.

once I was able to connect in the monring hours and the message was flashed 'registered on CDMA home network'. I was able to run an update. the kernel was updated with 3.0.2 -pae OR something similar (can find out if required). I surfed the net for about 2 hours later before restarting.

After the restart, again the Modem was not able to get me online. I kept trying for many times. I tried changing the setting in NM. One evening after dark I was able to connect to network with same message flash 'registered on CDMA home network' (the message was similar, i'm not precise here,sorry). I was able to surf the net for nearly 3 hours before I switched off my Laptop.

I'm not able to get online after that day, It's been 3 days now. I'll try the observered theory of late/early hours sometime soon as mentioned below.

Laptop configuration : Make: Lenovo Model: B480 Processor: Intel B950 RAM: 4G DDR3 HDD: 500 G Broadcom Wireless/Bluetooth/Ethernet LAN

OS: FreeDOS / Ubuntu 12.04 LTS (dualboot) - 32 bit Kernel 3.0.2-pae -32-bit

ISP: Reliance Communication (India) USB Modem: ZTE AC2726 (Black/silver)

Obeservation : I'm able to connect to internet in those hours when generally the speed is high (low usage by other network (wireless) users). like in early mornings or late nights. This is strange as connection should not be dependent on bandwidth usage.

Any help would be appraciated to fix this issue. before I decide to cahnge the OS or ISP.

  • Latest experiment was to delete the Mob-BB configuration. restart the machine. plug Modem. it identifies it as CDMA modem. then configure and enable the Mobile BB. this made it to connect 2-3 times. But when i tried that today it again failed. completely helpless. Moving back to 11.04 :(
    – Fredo
    Oct 12, 2012 at 8:47

1 Answer 1


I also faced the same issue, but somehow it worked for me after some tweaking.

Solution 1: (If you have access to Windows Machine)

Just go to the Reliance Netconnect Plus UI in Windows machine and in Settings change the 'Mode' to 'Hybrid'.

enter image description here

By doing this I found that the Reliance Netconnect Plus is recognized by Ubuntu quickly and

Now log in back to Ubuntu and connect to the internet through 'Network Manager'.

Using this method you will be registered on CDMA home network and can access the internet quickly.

The main disadvantage of this method is that we are running it under 'Hybrid' mode, which means that the internet may switch to 'CDMA 1x' mode and the internet speed will go down.

For me this happens only for 5-10 minutes then I'm again switched to fast Netconnect+ mode.

To overcome this disadvantage you may use Solution 2.

Solution 2: (Using WVDIAL)

If the Reliance Netconnect Plus modem works in Solution 1 then after connecting to internet, install WVDIAL


If you have access to GSM mobile(or GSM Modem) with cheap GPRS plan, then connect your mobile to Ubuntu through Network Manager and install WVDIAL. I have never experienced any difficulty with GSM Modem when connecting to Internet through Network Manager.

(i) Open Terminal (Keyboard Shortcut: Ctrl + Alt + T ) and type

sudo apt-get install wvdial

(ii) Open up wvdial’s configuration file using this command

gedit /etc/wvdial.conf

(iii) Paste the below code into the window that pops up ( make sure to enter your relevant details )

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = USB Modem
ISDN = 0
Phone = #777
New PPPD = yes
Modem = /dev/ttyUSB0 (This may also be dev/ttyUSB2 depending on where you plugged in your device)
Username = 9xxxxxxxxxx (your username, should be a number )
Password = 9xxxxxxxxxx (Your password , should be the same number)
CBaud = 460800

Delete all the comments in the brackets . The fields you should edit are Modem , Username and password the only ones with comment . Save and exist .

(iv) Thats it. Remove the GSM mobile(or GSM Modem) from PC/laptop and plug in Reliance Netconnect+ Modem. Wait till it gets recognized by Ubuntu, run lsusb command to know if it detected as modem and then

Run wvdial using following command

sudo wvdial

Internet using wvdial works out of box. Now you can change the Network Mode to 'Netconnect+' by using Reliance Netaconnect Plus UI in windows and log back to Ubuntu to use the uninterrupted broadband using wvdial.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.