this is my first post in the forums. I have tried many different distros, including ubuntu, lubuntu, xubuntu, linux mint, peppermint os,etc, and with all of them, I have had the same results. Ever since installing ubuntu, I faced problems with getting my wireless card to work. The network manager applet would tell me that I was connected with a wireless Port, but I would still be unable to use the internet (Browsers returning "not connected to network"). The problem exists with every ubuntu-based distro I tried.

My wireless card is an RT3090BC4 card. Even after installing the driver packages from the manufacturer, my wifi card would still fail to get me connected to my room's wifi, though it would continue to tell me that it was connected. Very recently, I realized that updating my kernel to versions over 3.4 would get my wifi card to work. However, installing ubuntu's mainline kernels seem to cause heating on my laptop's CPU and hard drive. The heating only seems to exist when the laptop is conncected to AC.

Is there a way to go back to kernel 3.2, while keeping my wifi driver functional? Or is there a method to cool down my laptop, even when I am charging? (My laptop doesn't heat up when I run windows 7.)


  • Hi and welcome to AskUbuntu. It is community policy to point you towards our fellow SE site - Unix & Linux. Peppermint is not an offical ubuntu variant and hence is off-topic here. Thanks.
    – fossfreedom
    Oct 10, 2012 at 7:26
  • okay, I've edited the question. The problem exists with all ubuntu Variants that I have tried, not just peppermint os. Oct 12, 2012 at 6:28
  • This site works best on trust - are you currently on an official ubuntu variant or peppermint?
    – fossfreedom
    Oct 12, 2012 at 7:33
  • jumped back to Lubuntu. Heating still exists, though... Oct 12, 2012 at 7:48

2 Answers 2


Well, most of the laptops heat up when you connect to charging. You can fix this most of the time by installing a proprietary display driver. Goto Settings>Additional Drivers and see if you can activate a proprietary display driver.

  • My laptop has a Nvidia GT540M intel integrated graphics card, and I already installed the necessary drivers, as well as bumblebee, for optimus support. the problem is that my laptop doesn't heat up when it runs windows7, even when I am charging. I'm pretty sure it's a software problem... Oct 9, 2012 at 6:41
  • hmm... Now that I check, I see that 'Framebuffer Driver for nVidia Chipset' is disabled. However, when I try to activate it, it returns 'this driver has not been activated, but it is being used"... Oct 9, 2012 at 6:52

You may want to update to the latest kernel (3.8 may be the best). It may also help to use a driver that is in the kernel instead of a proprietary driver. Often times, more than one driver can handle a device. Non-proprietary drivers are usually better to use on Linux system than the proprietary counterparts.
You may also be interested in filing a Linux kernel bug on Launchpad.net so that the Ubuntu developers can offer better support for your hardware and not heat up your CPU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.