4

I was wondering if I could install google chrome without using the sudo command.

I've tried to use the tutorials from google but I couldn't read it because I accidently downloaded the french version of Ubuntu, so I basically don't know what's happening, also, I'm a complete noob at Ubuntu... so if anyone could give me a very very basic tutorial on how to do it, it would be appreciated.

Thanks in advance.

3

There is no French version of ubuntu, it's just language you chose while installing ubuntu, you can change it if you wish.

The sudo command is for giving administrator privileges for an operation, admin privilege is necessary for installing a software, by the way, why don't you want to use sudo?

  • This is not an answer, and not true for the second part... – Sheljohn Apr 25 '14 at 8:52
3

I guess without sudo you cannot install google chrome. Because google chrome will try to install it in directory /opt and few other root directory, which needs sudo privilege.

But the alternative way is to install the chrome portable app. But to run a portable app you must have RUNZ framework

Follow the procedures in this link to install google chrome portable.

But I would recommend you to install the Google chrome with sudo permissions using the below commands

Add PPA to

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -

sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

Install Google chrome

sudo apt-get update
sudo apt-get install google-chrome-stable

Hope this helps

3

1)

cd
mkdir -p ~/local/pkg
mkdir -p ~/local/src/chrome
mkdir -p ~/local/bin

2) Download the package corresponding to your Linux distribution to the ~/local/pkg directory. If you're on Ubuntu, this is the .deb package.

3) Extract the package in the ~/local/src/chrome/ directory:

  • If .deb package: dpkg -x google-chrom...
  • If .rpm package: rpm2cpio ~/local/pkg/google-chrom... | cpio -id

4) Link libraries:

cd ~/local/src/chrome/opt/google/chrome/
ln -s /lib64/libbz2.so.1 libbz2.so.1.0
ln -s /lib64/libnspr4.so libnspr4.so.0d
ln -s /usr/lib64/libnss3.so libnss3.so.1d
ln -s /usr/lib64/libnssutil3.so libnssutil3.so.1d
ln -s /lib64/libplc4.so libplc4.so.0d
ln -s /usr/lib64/libsmime3.so libsmime3.so.1d

5) Add ~/local/bin/ to your path by pasting

for dir in "$HOME/local/bin"; do
  if [ -d "$dir" ]; then
    PATH="$dir:$PATH"
  fi
done

in your .bashrc file, then run source ~/.bashrc. Done!

  • 1
    In Trusty, ldd chrome complained about a missing libudev.so.0 which in fact does not exist on my system. /lib/x86_64-linux-gnu/libudev.so.1 does, but it seems like this was bumped up from .0 to .1 in Precise. However askubuntu.com/a/531098/49860 clarified that you can just make a symlink between them. I also had to add the directory with the symlink to $LD_LIBRARY_PATH, and make sure …/opt/google/chrome/chrome-sandbox was -rwsr-xr-x 1 root root, but then it worked. Workaround for poor Hangout support in Chromium. – Jesse Glick Oct 29 '14 at 21:15
  • Good to know, how did you chown the sandbox without sudo access though? – Sheljohn Oct 30 '14 at 10:17
  • In my case I did have sudo access, I just did not want to install Chrome as a package. – Jesse Glick Nov 3 '14 at 14:52
  • Best answer here. I like that this isn't just applicable just to chrome – Dylan Madisetti Jan 16 '15 at 13:39
  • By the way unix.stackexchange.com/a/8934/26736 seems very similar. – Jesse Glick Aug 3 '15 at 21:17
0
  1. Download the stable version of google-chrome from the home page

  2. Extract the downloaded package to a location of your choice

    e.g: with .deb package: dpkg -x google-chrom... path/to/google-chrome

  3. Run google-chrome from path/to/google-chrome/opt/google/chrome/google-chrome

  4. Follow this step if you wish to open google-chrome from your status bar. When google-chrome is open right click on the icon at the status bar then select lock to launcher option.

-1

You can use the latest builds of the chromium project and use it directly without sudo. All you would need to do is to extract the zip they provide and then execute it using terminal. You can look for more information in this method at how-to-install-chromium-zip-file

  • 1
    Please clarify if you have actually done so recently. – user25656 Jan 27 '13 at 11:01
  • @vasa1 No I havent. Any recent change that blocks this? – Karthik T Jan 27 '13 at 14:41
  • I'm asking mainly because providing an updated Chromium for Ubuntu isn't keeping pace. You may want to check this question. – user25656 Jan 27 '13 at 15:01
  • @vasa1 that question is talking about .debs right? Is it the same case for .zip? – Karthik T Jan 27 '13 at 16:49
  • That's why I asked if you've actually done so. It would be of interest to the community at large. – user25656 Jan 27 '13 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.