11

When I do a single click, my computer (with Ubuntu 12.04) acts like it was double click. I think it happens in ~50% of cases.

It happens with all the program I use: browsers, file manager, terminal and so on. I'm not sure when exactly it started, maybe a week ago, and I don't remember if it started to happen after system-update or after the installation of some packages.

What I tried:

  • change mouse
  • change mouse settings like Double-Click Timeout

None of those helped me. Any ideas?


UPDATE

This bug has disappeared after upgrading to 12.10.

4

3 Answers 3

2

If you've manually edited xorg.conf, try adding and entry for your mouse, in case it was somehow deleted:

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Source: http://ubuntuforums.org/showthread.php?t=1844513&page=2

EDIT As mention in the comments, this seems to be a reported bug that has stood for some time now. It may be best to add your info to Launchpad to help resolve the bug in the future.

2
  • Thanks for the answer, I added this section to xorg.conf but it didn't help :(
    – evfwcqcg
    Oct 10, 2012 at 18:19
  • I copied and pasted straight from the forum, so you may want to check the settings I've provided to match what you have.
    – Kyle Macey
    Oct 10, 2012 at 18:37
1

I had the same happen to me for no apparent reason a few days ago on 12.04. I went to nautilus Preferences..Behaviour and it had "Double click" option selected. I then selected single click, checked that was working, then went back and changed to double click again and bingo! Its back in double click mode!

1

I had the same problem on my laptop running Ubuntu 14.04.

Solution: If you are using a laptop try taking out its battery and then inserting it back.

Explanation: The problem was possibly caused by battery of my laptop. I noticed that though my laptop was fully charged and plugged in, its battery LED was changing color between orange (indicating charging) and yellow (indicating fully charged) continuously. So I removed my battery and inserted back to its slot (didn't switch off my laptop, so everything else remained same). This solved the issue, and since then the touch-pad is working perfectly fine.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .