I would like to set up my keyboard via my midi-sport 2x2, I've plugged everything in and even installed the midisport-firmware package which was not automatically installed for some reason.

The goal is to have the computer produce a piano sound when keys of the keyboard are hit. If you can make this work without jack, that would be good too. Step by step instructions, the less complexity the better.

3 Answers 3


OK I figured out the smallest number of steps to get this midi keyboard working:

  1. Install qsynth Install qsynth, Jack Control (called qjackctl) Install qjackctl, and download Claudio_Piano.rar from here, unpack and save in a handy place.

  2. Launch Jack Control (Applications > Sound and Video > JACK Control on older Ubuntu versions, or search for it in the Dash in newer Ubuntu versions)

  3. Click the settings button on the right side of the Jack Control panel, in the settings switch on midi input by going into the MIDI Driver drop down near the bottom of the window and selecting seq (alsa sequencer) and click OK.

  4. Load Qsynth, go into the setup, check Enable MIDI Input and turn the midi driver to alsa_seq, in the audio tab ensure the Audio Driver is set to jack, in the sound fonts tab open your downloaded sound font from above. Click ok and reset the server when it asks.

  5. If Qsynth freezes, unfreeze by stopping the jack server and then starting it again.

  6. Go back into the JACK Audio Connection Kit window and click Connect, here we are going to make sure in the Audio tab that qsynth is connected to the system output (drag handles).

    connect qsynth to output

    In the Alsa tab we are going to connect our midi device to qsynth.

    connect midi to qsynth

  7. Back in Qsynth Click on the Channels button and watch carefully all the little lights beside each of the midi channels. Press keys on your keyboard and see which one lights up. Click on that row and set the name to Piano (or whatever your musical instrument is)

  8. Play keyboard with sound output.

  • confirmed for Ubuntu 12.10. Added screenshots for step 6 where I hung up for an hour ... until I understood the explanation. Now, make music my friend!
    – somethis
    Sep 17, 2013 at 14:29
  • Up through step 7, where I see the light beside the row light up, everything works. I don't understand how to set the name to Piano though. So I did it in the "Preset Name" box, not in the row. Is that correct? After doing that, I still don't get any sound. I've obviously connected though, right? I'm sure of it since pressing keys will make the thing light up. I still can't figure out how to get any sound. I'm guessing I'm supposed to somehow connect the piano sound to this but I don't know how/where to do that.
    – Zamphatta
    Dec 31, 2013 at 0:19
  • Is it just me, or does this work but then regular audio can't be played? I'd ask a separate question, but I think the solution given here messes up audio settings so regular audio can no longer be played. Is this normal? If so it should explain how to get back to normal. Should I ask a separate question?
    – Nateowami
    Feb 4, 2016 at 8:26
  • Martin, please accept my kiss in feet. Worked like a charm. Dec 16, 2017 at 14:02

a solution using only alsa-utils timidity pmidi via the commandline is also possible.

  1. start timidity in the background

    timidity -iA -B2,8 -Os &

  2. find out the ports of the midi keyboard and timidity via

    pmidi -l

  3. connect the midi keyboard to the midi sequencer via aconnect port_midi_keyboard port_timidity e.g.

    aconnect 24:1 128:0


read this link... Step-by-step to run a midi keyboard input device? 12.04

and.. click on author to read more about what he has to say. extremely useful.

YOU MUST INSTALL THE LOW-LATENCY KERNEL ! you will find this via synaptic. this is critical.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.