4

I am trying to do apt-get dist-upgrade but I get the error:

E: Could not perform immediate configuration on 'util-linux'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

How can I resolve this?

2
  • My answer doesn;t apply now. Honestly, I don't know what to do, so I deleted my answer.
    – nanofarad
    Commented Oct 7, 2012 at 19:47
  • 1
    @ObsessiveSSOℲ: It was still helpful, though, because of the -O APT::Immediate-Configure=0 option.
    – Albert
    Commented Oct 7, 2012 at 19:56

1 Answer 1

7

Messed up system, I guess.

I tried to do apt-get dist-upgrade -o APT::Immediate-Configure=0 but I got a dependency cycle error: E: Couldn't configure pre-depend multiarch-support for libnih-dbus1, probably a dependency cycle.

Then I tried to apt-get install -f libnih-dbus1 and got another error:

The following packages have unmet dependencies:
  libc6-dev: Breaks: cmake (< 2.8.4+dfsg.1-5) but 2.8.1-4~lucid1 is to be installed
E: Broken packages`

Then I tried sudo apt-get install libc6-dev which worked.

Then I did apt-get install util-linux -f -o APT::Immediate-Configure=0 which also worked fine.

So I think this problem is resolved now.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .