I tried both aptitude -y safe-upgrade and apt-get upgrade -f but in both cases, I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages have been kept back:
... (long list)
0 packages upgraded, 0 newly installed, 0 to remove and 903 not upgraded.

I guess this resulted from several hacks where I tried to update my system (trying to work around this problem).

My question now: Why are they kept back? What can I do to install them?

On a similar question, I got the suggestion to just use apt-get dist-upgrade instead. However, that fails at the moment for me because of:

E: Could not perform immediate configuration on 'util-linux'.Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)

This is this problem.

1 Answer 1


After I did sudo apt-get install libc6-dev (because), this resolved all the kept-back packages (well, or maybe it was my apt-get dist-upgrade which I did after that, which failed though).

  • apt-get dist-upgrade is a likely fix for the typical "packages have been kept back" message. This helped on Ubuntu 12.04 LTS, not sure about other releases.
    – Mister_Tom
    Feb 9, 2016 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.