7

I'm not able to make a mic work with wine-1.7.30
(the mic is the integrated mic in my pc and works fine with other applications )

I found some suggestions but they don't seem to work. Anyone manage to fix this bug ?

Reference:

7
  • 2
    What Mic is it? Wine doesent Support USB. Mar 19, 2013 at 10:43
  • The mic is the integrated one in my labtop. I'm tring to use it in r. stone with wine Mar 22, 2013 at 12:59
  • @prophecy201 I've managed to use a Microsoft Lifecam USB webcam's microphone in Rosetta Stone using Wine. So I think that your comment is somewhat invalid then... I've previously upvoted it but finally succeeded in proving it false. :)
    – masu
    Nov 4, 2014 at 15:04
  • 1
    To answer the original question: try using the WINENOPULSE=1 option when you create the winebottle. I also used playonlinux with wine.
    – masu
    Nov 4, 2014 at 15:18
  • 1
    Is your mic working in Ubuntu (when not using wine)?
    – Sukarn
    Nov 8, 2014 at 8:33

2 Answers 2

3

As suggested by @Masu WINENOPULSE=1 parameters fix the issue.

There should be a way to make this setting as default in wine but I cannot find it right now.

For the moment I'm using a manual approach:

env WINENOPULSE=1 wine YOUR_PROGRAM.exe

Or you can add it to the launcher:

Taking care that Wine launchers are stored in: ~/.local/share/applications/wine/Programs/
You just have to edit the program launcher and add WINENOPULSE=1 to the exec line.

So for Rosetta Stone the launcer will be changes as the following one:

[Desktop Entry]
Name=Rosetta Stone TOTALe
Exec=env WINENOPULSE=1 WINEPREFIX="/home/fra/.wine" wine C:\\\\windows\\\\command\\\\start.exe /Unix /home/fra/.wine/dosdevices/c:/users/fra/Start\\ Menu/Programs/Rosetta\\ Stone/Rosetta\\ Stone\\ TOTALe/Rosetta\\ Stone\\ TOTALe.lnk
Type=Application
StartupNotify=true
Icon=C722_RosettaStoneTOTALe.0
2
  • not work on wine 1.8
    – A1Gard
    Apr 6, 2017 at 22:08
  • it was 2yrs ago and I am not using the mic/wine anymore ... If you find a solution please update the above answer or add your answer to this question thx. Apr 8, 2017 at 3:14
3

Change the default audio in Wine to Alsa only. You can change it via winetricks: Select the default wineprefix -> Change settings -> Check sound=alsa

An answer to this question shows how to do that using pictures.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.