Yesterday, after turning on Ubuntu, I logged into a Gnome session. A few minutes later, I tried switching to Unity for a change. Unfortunately, the background and my desktop icons loaded, but the system bar and launcher failed to load even after several minutes. Unity had always worked fine for me.

I then tried the guest account, and it worked fine on both Unity and Gnome. However, the problem with my account got worse; I couldn't log into any desktop at all anymore. I would type in my password and press enter and it would just sit there doing nothing. The computer no longer responded in any way, so I had to hold the power button and reboot. The same problem happened repeatedly.

Earlier today, I tried to get on again. I found that I hadthe same problem, when I tried to log in, the computer no longer locked up, but instead flashed a black screen with theconsole output and what seemed to be an error message before returning to the log in screen. It was to quick for me to read, about 1/4-1/2 second.

I'd really appreciate some help as I have some important files that are not backed up yet. I can't transfer the files to a new account, or even make a new account because I tried taking the password off my account so now I can't authenticate from the guest to perform root functions.

I'd really appreciate some help as I have some important files that are not backed up yet. Thanks.

  • Try creating a new user account and log into Gnome and Unity to see if both work ok. If so, the problem is with your user. – LnxSlck Oct 6 '12 at 23:19
  • I can't create a new user because my account, the admin, has no password. – Razick Oct 7 '12 at 11:46

You can get in your account from the terminal without GUI and back up the files or fix some issues from there.

Hit Ctrl+Alt+F1, and you'll see a login prompt. Log in and do your stuff, from the command line.

You can create a new user from the command line like this:

sudo adduser <newusername>

If you want to get back to GUI desktop, hit Ctrl+Alt+F7.

  • I found out I have the files I need in Ubuntu One. So I'm reinstalling. This did help me make some progress and I think would have worked though, so thank you! – Razick Oct 8 '12 at 22:44

I ran into the same issue. The problem was in the user .XAuthority file permission was owned by the root user. I changed the file permission and was able to log back in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.