I'm very noob at Linux and installing techniques. I want to install 12.04 from bootable usb flash alongside Windows 7 (also tried live CD but not working) but computer is not booting from USB flash or LIVE-CD and boots windows 7 (Acer Aspire 4750g) and of course I have set the BIOS priority in the right way.

There is one important point to tell that I have installed Fedora 16 on my laptop successfully and now I have it on my system. When I was trying to install Fedora I got some error and searched about it and got this point that I should delete a .efi file and then installation went right.

In this case , what should I do to solve the problem? (I also don't need my Fedora anymore).

  • have you downloaded Ubuntu 12.04 LTS from online or did you purchase the USB stick? – user95008 Oct 6 '12 at 20:25
  • downloaded iso file and made it a bootable usb flash – Aliweb Oct 6 '12 at 20:30
  • Did you try booting other bootable discs? In some Bios settings, setting boot order USB → HDD is not enough. You have to go to HDD and set removable USB before HDD there. – To Do Oct 6 '12 at 20:57
  • I also tried that , and also tried the way @fabricator4 said. It doesn't boot at all. – Aliweb Oct 7 '12 at 8:24
  • make sure that your computer knows that you wana boot via usb aKa check bios – Nick Bailuc Oct 8 '12 at 2:27

Before proceeding further, it's imperative that you determine how Windows is booting: in BIOS (aka legacy) mode or in UEFI mode. This is tied to the partition table type: In BIOS mode, Windows must boot from an MBR disk, whereas in UEFI mode, it must boot from a GPT disk. This is described in more detail here. Installing Linux in the wrong boot mode is likely to be a recipe for frustration; for best results, the boot modes of both OSes must match. If they don't match, you'll have to jump through extra hoops to get them to match or to switch your computer's boot mode whenever you boot.

Once you know the boot mode, the question becomes: How do you boot the Ubuntu installer in the desired boot mode? In some cases there are two boot options for CDs and/or USB drives in your firmware's boot-time boot menu, so once you access it (typically by pressing F2, F10, F12, or some other key at boot time), you can select the appropriate boot mode and continue. It's easy to overlook the distinction between these options, but one typically mentions "UEFI" (for UEFI) or "legacy" (for BIOS). Unfortunately, some firmware implementations don't give you the sort of control you should have, so you might not see these options. Also, there are sometimes bugs, particularly with UEFI boot mode, that can make it very difficult to get started; you may need to replace one EFI boot loader with another. Alternatively, you could install in the "wrong" mode (despite what I just wrote about that being bad) and then switch the boot mode later by manually installing the correct type of boot loader. Debugging such problems is system-specific and so is better handled in forums than on a site like this one.

| improve this answer | |
  • as I said , My boot mode should be BIOS. but I don't how to do that. I said for installing Fedora , somebody told me to delete a .efi file and it worked for me then. but I didn't find a similar option in ubuntu files. Do you have any suggestions about this case? – Aliweb Oct 8 '12 at 14:14
  • See the link in my original response: rodsbooks.com/refind/bootmode.html. That provides information on how to determine your boot mode. – Rod Smith Oct 8 '12 at 23:07
  • 1
    I don't want to determine my boot mode. I said I know it is BIOS mode. The problem is this : my laptop doesn't boot from ubuntu to install in any way. – Aliweb Oct 9 '12 at 20:19

Enter the BIOS with F2 as the machine is going through post. Enable the boot menu in BIOS and you will now be able to access the boot menu as the machine is going through post again with F12.

Select the boot device you want to boot from - either the LiveCD or the LiveUSB.

| improve this answer | |
  • 1
    Tried that. not working. please note the point I told that in installing Fedora 16 , I deleted the .efi file to boot in correct way. I think it's called BIOS based partitioning. – Aliweb Oct 7 '12 at 8:25
  • What's not working, the BIOS setup program or the Boot menu? – fabricator4 Oct 7 '12 at 9:40
  • BIOS setup works. and I enabled boot menu in BIOS. then restart and press F12 and boot options appear. Then I choose Silicon power (my usb flash), but after a bit delay , it loads GNOME and says choose between Fedora and Windows (as before) ... – Aliweb Oct 7 '12 at 14:08
  • to enter bios its not always F2, thats for toshiba and hp. for asus and dell its the delete key – Nick Bailuc Oct 8 '12 at 2:28
  • 1
    It's defaulting back to boot loader on the hard drive for some reason. Did you check the md5sum for the iso you downloaded. Will the USB stick boot OK on another computuer? – fabricator4 Oct 10 '12 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.