Firstly i want to apologise for any mistakes, English is not my native language.

My problem is I can't get NVIDIA proprietary drivers to work. I tried to install it on Ubuntu 12.04.1 32 and 64 bits, Ubuntu 12.10 Beta 2, Linux Mint 13 Cinnamon 64 bits and openSUSE 12.2 64 bits and the error code and symptoms (logging to tty1 instead of GUI logging, low-res bootscreen) are the same for all of these distros.

Right, I didn't tell what's the error code. It appears on sudo startx.

NVIDIA: could not open the device file /dev/nvidia0 (Input/output error).

I know that's the common problem, but I tried to blacklist or even remove the noveau drivers, install NVIDIA driver from repo/from official script/in "Additional drivers", editing xorg.conf and using Xorg -configurate and nvidia-xconfig, actualizing the kernel and entire distro and many, many things that I don't remember. But the problem is even better: entire Cinnamon (Mint) is freezing during the work. I found the error code, which appears during the freeze:

Oct 1 20:57:17 WoozieLaptop kernel: [   308.120176] [drm] nouveau 0000:01:00.0:   PFIFO_CACHE_ERROR - Ch 4/1 Mthd 0z0060 Data 0xbcef0201

My Xorg.0.log is here. It was made on Ubuntu 12.04.1 after installing NVIDIA drivers (obviously).

inxi -G from Mint:

Graphics:    Card: NVIDIA GT216 [GeForce GT 240M]
             X.org: 1.11.3 drivers: (unloaded: nvidia)   FAILED:  nouveau,vesa,fbdev
             tty size: 80x25 Advanced Data: N/A for root out of X

lspci -k | grep -A2 VGA from Mint:

01:00.0 VGA compatible controller: NVIDIA Corporation GT216 [GeForce GT 240M] (rev a2)
   Subsystem: Lenovo Device 38ff
   Kernel driver in use: nvidia

My hardware is:

  • Lenovo IdeaPad Y550
  • Intel C2D T6600
  • NVIDIA GeForce GT 240M
  • 4 GB of RAM

Any help will be appreciated. This problem totally disabled my laptop from daily using.




There are a number of problems with the nVidia drivers that are contained within the 12.04 repositories (check ubuntuforums.org and do a search).

I have had two nVidia cards, neither of which worked with the standard drivers. There is a PPA that seems to work very well, and may fix your problem.

Since you are already at a console, please execute the following commands. When you execute the commands, you will need to provide your password (which will appear blank). You will also be asked to confirm the commands (after a brief display). You may press the Enter key to confirm the commands:

The following will add the repository to your source list:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

The following will update your software repository list:

sudo apt-get update

The following will add the nvidia driver from the PPA:

sudo apt-get install nvidia-current

The following will update your x-windows configuration:

sudo nvidia-xconfig

The following will reboot your system:

sudo reboot

If all goes well, the new nVidia drivers will be installed and you will have the graphical desktop.

If you select Dash, then type nvidia, you will get the nvidia settings program. You may adjust the settings appropriate for your nVidia card here.

Hope this helps,

  • 1
    Still the same problem. :< – Woozie Oct 6 '12 at 17:01

Try dpkg-reconfigure lightdm.

Have you tried installing gnome instead of unity, to see if it works?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.