I have an accounting program specifically tailored to the IT industry, its called Fincon (exe based). It basically works on a client to server directory base system. the server is currently running on a windows 7 machine with a NTFS partition. I have installed Wine. Have the shared Windows directory mounted with what I assume is the correct command for such being (mount -tsmbfs //servername/sharedir /mnt/fincon -0 usename=username,password=password).

I can see the shared dir although it does take a bit long to access it on the Ubuntu machine via the mapped directory but instant via normal network browsing.

I have also set up the mapped directory to my D: drive in Wine and have pointed the fincon.ini to read server field from D: directly.

Here's my issue, it seems that for some odd reason I cant write to the mapped directory from Ubuntu, yet I can with my Windows machines, the permissions are set correct on the Windows 7 share and I really dunno what I'm missing.

I'm quite a Linux noob just switched yesterday.

Thanks guys for any help in this would be quite appreciated. As I'm pulling out my hair here and really want to migrate my work PCs to a Linux OS as it just gives less issues than Windows does ever.


First of all, I would like to suggest that you switch from SMBFS to CIFS, since the former is no longer under development.

To do so, you merely have to install the package called cifs-utils (supposing you are running Ubuntu >= 10.10, if you use 10.04 or earlier, just stay with the smbfs package).

Then you can simply mount your share-- writable --with

sudo mount -t cifs -o rw,username=username,password=password //<Server>/sharedir /mnt/fincon

Please mind the option rw, which basically gives you read and write access!

You also can put your share into fstab, but that would require you to put your password in plain text into this file, which can be read by every user on the system.

You could also use a credentials file, which can only be read by you and root, but I don't like this variant, since it still needs your password in plain text.

You could also mount the folder automatically at login, if your account password on your local machine is the same the password as for the samba share. (Here you use pam_mount.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.