I need to install php-apc on Ubuntu 10.04 and Ubuntu 9.04

First of all, can I just install this package to make it work with php 5.2 + lighttpd on these Ubuntu versions ?

I've tried to install it on Ubuntu 10.04 and I get the following error:

sudo apt-get install php-apc

The following packages have unmet dependencies:
  php-apc: Depends: phpapi-20090626+lfs
E: Broken packages


  • I realize it has been awhile since activity on this but did you ever get this resolved. I am dealing with the same issue. Thanks.
    – davedpss
    May 21 '12 at 20:22
  • fluteflute's answer has been accepted, so you might try that and see if it works. If it doesn't, you should post a new question detailing your problem and also including a link to this question. (Your post here will probably be deleted soon, since it is posted as an answer but is not an attempt to answer the question.) May 21 '12 at 20:28

php-apc cannot be installed because it depends on the virtual package phpapi-20090626+lfs. For the system to consider this virtual package 'installed', then you need to have installed either Apache or PHP.

Seeing as you don't need Apache I would suggest you install the php5-cgi package. (This will give you PHP 5.3 in 10.04.)

  • I actually don't want to upgrade to php 5.3, because it doesn't support Drupal 6 yet. Can I make it with php 5.2 ?
    – aneuryzm
    Jan 2 '11 at 8:39
  • @Patrick according to the drupal website you can use PHP 5.3 with the latest Drupal 6 releases
    – 8128
    Jan 2 '11 at 8:43
  • 1
    I know but it is an optimistic statement. I work with it and some modules are not properly working. Trust me.
    – aneuryzm
    Jan 2 '11 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.