I have a Toshiba Satellite R830 laptop with Ubuntu 12.04.1 64 bit. The Fn + F6 and Fn + F7 buttons adjust brightness until I put my laptop on sleep.

On wakeup they don't work any longer. Is there a solution or a workaround to this issue?

2 Answers 2


I found a better solution than the one selected above.

  1. Press Alt + F2 and type gksudo gedit /etc/default/grub.
  2. Find the line than starts with GRUB_CMDLINE_LINUX_DEFAULT= and modify it as follows: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor".
  3. In a terminal (ctrl + alt + T) type sudo update-grub.
  4. Reboot.

Problem solved.

More info here: https://wiki.ubuntu.com/Kernel/Debugging/Backlight


This solution no longer works on 13.10 and 14.04.

A solution that does is creating an xorg configuration file:

  1. In a terminal type sudo touch /usr/share/X11/xorg.conf.d/20-intel.conf to create the file.
  2. Followed by sudo gedit /usr/share/X11/xorg.conf.d/20-intel.conf to edit its content.
  3. Then add the following content and save:
Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"


Log out and in again.

Source: Fix Brightness Control Not Working for Ubuntu 13.10 & 14.04

  • You're adding a kernel parameter. Could you post a link, or directly describe why this is needed?
    – Geoff
    Dec 13, 2012 at 14:39
  • See modified answer. Not that I understand the details of it.
    – To Do
    Dec 13, 2012 at 14:43
  • The second solution worked for me on Toshiba R830-13D running Fedora 21 Workstation with kernel 3.17.8. Jan 20, 2015 at 7:09
  • Solution Ubuntu 14.04 also work for Lenovo T400! Thanks!
    – lechup
    Feb 26, 2015 at 14:51
  • The first solution worked on an Asus Zenbook with Debian Jessie (kernel 3.16.0), however, I had to remove the backlight part because with that I couldn't change my backlight.
    – user125111
    Jun 30, 2015 at 8:27

I had the same problem with a Toshiba Portege R935 in 12.04, and I discovered this (not so elegant) workaround:

  • as root (not with sudo but actually changing user: su root), change the value in sys/class/backlight/intel_backlight/brightness

    for instance:

    echo 2937 > /sys/class/backlight/intel_backlight/brightness

Warning: these values are not between 0 and 7 (as the ones in the other directory), but between 284 and 4539, or something like that.

  • Do you have to do it every time you need to change the brightness?
    – To Do
    Oct 5, 2012 at 21:01
  • 2
    Well, yes, but I guess you can create a shortcut as the proposed solutions in other posts. I haven't do it yet, I'll let you know if I try. At least it's good to know where the problem is...
    – mfiori
    Oct 6, 2012 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.