851

When I log into my web server via SSH I see the information:

88 packages can be updated.
80 updates are security updates

I tried apt-get update then apt-get upgrade but each time I log in I still see the message about updates. How do I install them?

1
  • 3
    Did you try this first: sudo apt-get clean this should clean the cache. Sep 20, 2013 at 16:02

9 Answers 9

1077

Use this:

sudo apt update        # Fetches the list of available updates
sudo apt upgrade       # Installs some updates; does not remove packages
sudo apt full-upgrade  # Installs updates; may also remove some packages, if needed
sudo apt autoremove    # Removes any old packages that are no longer needed

Documentation about each apt option can be found in the the manpages for apt. These are also available by running man apt in your terminal.

Use of both upgrade and full-upgrade together is usually not needed, but it may help in some cases: see Debian documentation about Upgrades from Debian 9.

5
  • 37
    Should I always restart with sudo reboot after it?
    – hellboy
    Apr 9, 2015 at 5:47
  • 1
    I needed to add -y for it to work. Ubuntu 17.10
    – T04435
    Feb 24, 2018 at 21:21
  • 4
    @hellboy No need to every time. It will usually inform you if a reboot is required. Jun 12, 2020 at 2:15
  • 5
    Just pointing out that apt full-upgrade performs the same function as apt-get dist-upgrade, if, like me, you're comparing the commands with other answers in this question.
    – kas
    Jul 31, 2020 at 15:35
  • @hellboy It will tell you if a reboot is required. Also it's unclear whether you're asking if rebooting command line is required - the answer is No. It doesn't matter how you restart the machine. Jan 20 at 21:45
157

Execute all the commands by typing sudo once:

sudo -- sh -c 'apt-get update; apt-get upgrade -y; apt-get full-upgrade -y; apt-get autoremove -y; apt-get autoclean -y'

or:

sudo -s -- <<EOF
apt-get update
apt-get upgrade -y
apt-get full-upgrade -y
apt-get autoremove -y
apt-get autoclean -y
EOF

or even shorter in a for loop (thanks @dessert!):

sudo bash -c 'for i in update {,full-}upgrade auto{remove,clean}; do apt-get $i -y; done'
0
98

This is normal behavior.

The message you see on login has been appended to the server status 'Message-Of-The-Day', which is only updated each calendar day (or on server boot / startup). Have a look at the contents, using

cat /etc/motd

Still seeing the same updates available, after running

sudo apt-get update && sudo apt-get upgrade

is to be expected. If you then re-run this command you will only be prompted for any further updates if even further (newer) updates have been released.

8
  • I'm noticing that any file changes in the whole system doesn't show until the next calendar day, is there a way for like "refresh" to start seeing changes right away?
    – 3lomahmed
    Feb 11, 2016 at 7:24
  • Do you mean updates for the content of Message-Of-The-Day, or not getting what you want after running sudo apt-get update && sudo apt-get upgrade ?
    – david6
    Feb 11, 2016 at 7:35
  • 3
    This is no longer true on 16.04. After "apt-get dist-upgrade" and a reboot I see "0 packages can be upgraded". Jun 24, 2016 at 18:27
  • 2
    The '.. or on server reboot ..' statement above does cover that.
    – david6
    Jun 24, 2016 at 20:29
  • 3
    cat: /etc/motd: No such file or directory
    – xApple
    Jan 26, 2017 at 19:17
13

Once your log into your server, run the command below.

sudo apt-get upgrade

It should do the trick. Maybe you just need to restart your server.

4
  • 3
    Thank you for your answer but I did try sudo apt-get upgrade. Restarting the server is out of the question because I have sites on it.
    – Marlin
    Oct 5, 2012 at 14:04
  • 3
    if you installed an update that directly affects the kernel or it's a driver update or it's a critical security update, you need to restart the server. Oct 5, 2012 at 14:11
  • Maybe you should consider an error 503 for a minute. Do you know what kind of update this is ?
    – NorTicUs
    Oct 5, 2012 at 15:09
  • 2
    How can you give a 503 if the server is offline?
    – mcont
    Jan 12, 2015 at 13:58
9

In my case, I had an incorrect or not accessible URL in /etc/apt/sources.list. After removing this URL, I was able to update all packages successfully.

Commands:

sudo vi /etc/apt/sources.list
sudo apt-get update && sudo apt-get upgrade
8

My (really late, I like necromancer badges :-) ) solution:

  1. Install wajig (once):

    sudo apt-get install wajig 
    
  2. When you want to update/upgrade fully your system

    wajig dailyupgrade
    

    (it will ask for password if needed, and do all the update, upgrade, dist-upgrade, and autoremove steps for you).

4

You may also need to do this -

sudo touch /etc/motd.tail

From - Ubuntu tells me I have packages to upgrade when I don't

It worked for me on 14.04

1

If you run apt-get update again after apt-get upgrade has been concluded, those messages at ssh login should go away.

0

this script is handy to automate updates including removing unneeded packages and performing a reboot only if the OS wants one

remote_user=usernamehere
remote_host=example.com

ssh -A -n -o StrictHostKeyChecking=no ${remote_user}@${remote_host} && \
sudo apt-get update && \
sudo apt-get -f install -y && \
sudo apt-get -o Dpkg::Options::="--force-confnew" -yy dist-upgrade -y && \
sudo apt-get autoremove -y && \
[ -f /var/run/reboot-required ] && \
echo "sudo reboot now" && \
sudo reboot now 

to run on your local box just leave off that first line doing the ssh

here is an alias I save in ~/.bashrc

alias doit='echo; kill $( ps -eafww|grep update-manager|grep -v grep | grep update-manager | tr -s " " |cut -d" "  -f2 ) > /dev/null 2>&1;  echo "sudo apt-get update && sudo apt-get dist-upgrade &&  [ -f /var/run/reboot-required ] && echo && echo reboot required && echo";echo;sudo apt-get update && sudo apt-get dist-upgrade &&  [ -f /var/run/reboot-required ] && echo && echo reboot required && echo '

then on terminal I just issue doit

Not the answer you're looking for? Browse other questions tagged or ask your own question.