I have installed 7pzip and peazip to handle archives but after setting one of them as default and using Extract here or Compress/Create archive I am prompted as below

enter image description here

Selecting one in the list makes it the default archive manager, overwriting my previous setting.

This happens in PCManFM and Thunar, but not in Nautilus.

PCManFM is my default file manager as I am in Lubuntu 12.10 and have to keep using that.


I had similar problems with the default file type program associations in ubuntu. You probably need to choose on of those in the list for the auto extract here options to work nicely. That does not mean that you cant change the default archive managing application.

These posts go into some detail about how to change the association manually by editing the files used to map file types with programs.


Where are file associations stored?

How can I change the default text editor from gedit to vim?

To change the stored associations, and priorities. ie which app show up first in a list have a look here.

gvim ~/.local/share/applications/mimeapps.list

Try creating a new entry in the open with menu. I am not sure this will work as different command line programs use different options. A little experimentation my be need to get this working correctly. The problem is most probably linked to the parameters that pacman passes to application.

First, to get 7z (or any app) into the "open with other application" list, you need to create a .desktop file in ~/.local/share/applications with a line in it like this: Exec=<command> %f. I just made one called 7z.desktop with these lines:

[Desktop Entry]
Comment=Edit file in Vim
Exec=7z %f
GenericName=Process Viewer
  • thnx, but as i said in the question i have no problem with nautilus. pcmanfm is my problem, for i am in lubuntu and have to stick with pcmanfm... creating new options in menu is very easy with thunar and nautilus. and not the creation of new menus is the problem, but setting a program in pcmanfm (and thunar) to act for "extract here", other than the three listed in the image. (this works in nautilus) – user47206 Oct 7 '12 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy