I have scoured the Internet trying to find a solution to my problem.

I have a Toshiba L755D-S5171 and like many people the Fn key works to a very small extent.

The Fn+3/4 works to vol-down/up and Fn+Esc works to mute like many have reported.

I have looked for that "BIOS option" some users speak of, and there isn't one for my model. I have installed Fnfxd and fnfx and all that Jazz but no cigar.

Like one user I noticed recently my Fn+F6/F7 keys "work" after a suspend (they show brightness bar and it changes, but no real change to brightness) and i can softblock my WiFi, all after a suspension, but they still do not actually work as designed.

I don't know if there is an answer out there, but if there is I would like to be told or pointed to it.

I really like Ubuntu and would like to use it on a regular basis for everything but gaming, but if i cannot change power consumption options on the fly then Windows will work better for me.

I see alot of posts/threads asking for help, and only a few replies that work for a few people.

All I really need to work is the WiFi, I do a lot of stuff online, and a lot of stuff offline, and if I am traveling I don't want to have to restart my computer to turn off WiFi in the BIOS.

  • Toshiba L755D-S5171 650Gb
  • HDD = 70Gb Ubuntu 12.04 AMD64, 580Gb Windows 7 Home Premium x64
  • AMD Llano A6 3420 1.5Ghz Quad core
  • 4GB 1333 DDR3 204pin RAM

Open terminal (Clt + Alt + T) and run the command given below:

sudo gedit /etc/default/grub

Now the new window opens and you will see the lines given below:


Now you have to change the lines above by the command lines given below:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

Then save the window and Update the grub from the terminal using:

sudo update-grub

Now you can increase or decrease the brightness in PC with Latest Ubuntu in it.


Source - Blog


Couldn't change graphics with Fn keys on my Acer laptop.

This helped me, added to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"

Then runupdate-grub and reboot.

Source: http://www.refreshit.info/2012/08/solved-brightness-increase-and-decrease.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.