8

In my ubuntu 12.04, the graphviz is not the latest version(2.29). I need some features available in the latest version of graphviz. I tried to install the graphviz version 2.29, which requires libgraphviz4(>=2.18). I anyhow installed libgraphviz4 and installed graphviz 2.29. For that I have to remove packages libcdt4 and libpathplan4.

Now whenever I try to generate graph, I get some problems: For e.g.:

dot -Kfdp -n -Tpng -o samplePOS.png forcePOS.dot

It says:

dot: error while loading shared libraries: libgvc.so.6: cannot open
shared object file: No such file or directory

neato -Tps -o sample_1.ps sourcedot.gv

It says:

neato: error while loading shared libraries: libgvc.so.6: cannot open
shared object file: No such file or directory

So, I am looking for some ways so that I can run graphviz 2.29 in my ubuntu 12.04.

14

First a warning for using PPA (mainly unstable)

The below PPA: ppa:dperry/ppa-graphviz-test is an unstable PPA. So, you are given warning.

Use this commands in a terminal to install the unstable 2.29 version of graphviz.

sudo apt-add-repository ppa:dperry/ppa-graphviz-test
sudo apt-get update
sudo apt-get autoremove graphviz
sudo apt-get install graphviz

If you get this error "graphviz : Depends: libgraphviz4 (>= 2.18) but it is not going to be installed", run the following

sudo apt-get remove libcdt4
sudo apt-get remove libpathplan4
sudo apt-get install graphviz
11
  • I followed these steps But it is not able to install the latest graphviz version. I encountered the same problem which I have stated in the beginning, i.e. requires libgraphviz4(>=2.18) imageshack.us/f/17/screenshotfrom201210041.png – bidur Oct 4 '12 at 7:20
  • If you have previous installation of graphviz, remove it completely – Anwar Oct 4 '12 at 7:25
  • Thank You very much. I could install graphviz 2.29 after removing packages libcdt4 and libpathplan4. – bidur Oct 4 '12 at 7:33
  • This installs 2.26.3 again for me. Any idea why? – KomodoDave Oct 7 '12 at 18:32
  • I think it's because the latest build in PPA author's repo failed on Precise Pangolin x64, so if you're using 64 bit Ubuntu 12.04 like me, watch out. – KomodoDave Oct 7 '12 at 18:43
3

Ubuntu 12.04 here.

What worked for me is:

  1. Remove the following packages

    sudo apt-get remove libcdt4
    
    sudo apt-get remove libpathplan4
    
  2. Install libgraphviz4

    http://www.graphviz.org/Download_linux_ubuntu.php

  3. Install graphviz

    sudo apt-get install graphviz
    
0
0

Since you mess with some libraries i advice you to remove graphviz and install again

sudo apt-get remove graphviz
sudo apt-get remove graphviz-dev
sudo apt-get remove graphviz-doc
sudo apt-get install graphviz

This is a same situation for other user

3
  • I tried this but this will install graphviz (2.26.3-10ubuntu1) NOT the latest version 2.29 – bidur Oct 4 '12 at 6:34
  • But 2.29 still not stable. I advice you to stay at 2.26.3 as Ubuntu propose to avoid such conflicts – user61928 Oct 4 '12 at 6:37
  • even I wish to stay with the stable version but I need some features provided by the version 2.29 – bidur Oct 4 '12 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.