15

i was finishing up a job with a compact flash when, trying to unmount it:

#> umount /dev/sda2 
umount: it seems /dev/sda2 is mounted multiple times

Looking at what mount says:

#> mount | column -t | grep sda2
/dev/sda2  on  /mnt/flashrw  type  ext3      (rw,nosuid,nodev)
/dev/sda2  on  /mnt/flashrw  type  ext3      (rw,nosuid,nodev,user=myuser)

it seems that I accidentally mounted the same device on the same location (though in two different ways).

I tried to unmount it many times also with:

#> umount /mnt/flashrw 
umount: it seems /mnt/flashrw is mounted multiple times

with no luck. Finally, I tried:

#> sudo umount -f /dev/sda2

but umount locked completely.

So the question is: and now?

24

Try running this command:

sudo umount /mnt/flashrw
  • 3
    Yup, fixed it for me. That was the most misleading error message I have seen in a a while. – Laurens Holst Jan 13 '13 at 1:45
  • what if you do not have sudo access on the server – user5359531 Jun 18 '18 at 15:26
0

Most probably it was a kernel bug due to an unstable patch interaction. I was using a 3.4.11 vanilla kernel patched with the corresponding RT-PREEMPT patch by Ingo Molnar.

Due to a severe memory leak, I moved to 3.6.4 vanilla + RT-PREEMPT patch and now the system seems to be really stable. The problem has never presented again. Hope this may help someone in the future.

  • Why is this marked as the answer? – JamesH Dec 15 '17 at 22:51
  • 1
    Because it was what really was happening to me. It was not the beginner use case "I can't umount my usb pen and I don't even know about the existence of lsof or fuser", it was a kernel issue due to an unofficial (and problematic) kernel patch applied to a custom kernel. – Avio Dec 18 '17 at 13:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.