Whenever I edit my /etc/hosts file it's not long before I find it is exactly what it was before I edited it. Is there some master file I should be editing, or a gui interface I'm supposed to be using to edit it?

I'm still on Natty.

  • Are you working with VPN? – user61928 Oct 3 '12 at 12:22
  • do you have dnsmasq in your system? – user61928 Oct 3 '12 at 12:23
  • No vpn, but it looks like dnsmasq-base is installed. I'll look into that and update on results. – Rob Mosher Oct 3 '12 at 23:14
  • Seeing this problem on 15.04 as well. – jerome Oct 9 '15 at 14:12

According to this post your problem is caused by one of the three possibilities:

1.It's due to dnsmasq defaulting to sys dns settings.



2.You need to update .

3.Any changes you make to /etc/hosts or /ets/resolv.conf during the VPN session are wiped out when you disconnect from the VPN

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.