My xubuntu 12.04 has worked flawlessly since install in September. However, lately I randomly have the following boot issue :

The computer boots to grub, and after choosing xubuntu either boots normally or boots to a black screen.

Here are some observations I have made :

  • The black screen seems to happen randomly.
  • The black screen does not seem to happen in safe mode (- nomodeset in grub).
  • The black screen does not allow me to ctrl + alt + F1-6 into a terminal.
  • The black screen allows me to use SysRq keys (Alt + SysRq + K does not work though).
  • The black screen often happens on first boot in several hours and the computer usually boots normally after a RSEINUB.
  • When the computer boots I get "SP5100 TCO timer: mmio address 0xfec000f0 already in use" at startup and "Could not write bytes: broken pipe" at shutdown. However research on these errors did not yield answers to my particular issue.
  • Comparing Xorg.0.log (successful boot) and Xorg.0.log.old (black screen), and reading the answers to similar problem, it seems that I might have a X driver issue. However the system worked flawlessly until lately.

Additional info on my system :

  • ACER AO722 C62kk
  • Operating system : 3.2.0-31-generic ubuntu

Edit : I made a fresh install of Xubuntu 12.04 x64, the issue is still there ... (I have a separate /home so config. files were not erased).

Edit 2 : I followed troubleshooting blank screen, so my new observations are without quiet and splash in grub :

  • When the system boots normally, the screen goes black after grub then lights up and displays text information then goes to login screen. (After that the desktop starting time vary substantially, which is new and may be a separate issue ?).
  • When the boot fails, after grub the screen goes black, lights up, goes black, lights up again and most times goes black again. At this point it responds to Alt+SysReq K by lighting up but no more, and has to be rebooted through Alt+SysReq+ RSEINUB.

Edit 3 : I tried to remove all .* configuration folders since a fresh install did not fix the issue, but it did not work ...

Edit 4 : I reinstalled grub2 from scratch and the issue still exists. However I checked my kern.log file and the following errors appear when I have the blank screen :

Oct 19 07:49:00 thibaud-AO722 kernel: [   37.856526] [drm:r600_ring_test] *ERROR* radeon: ring test failed (scratch(0x8504)=0xCAFEDEAD)
Oct 19 07:49:00 thibaud-AO722 kernel: [   37.856539] [drm:evergreen_resume] *ERROR* evergreen startup failed on resume
Oct 19 07:49:00 thibaud-AO722 kernel: [   37.952276] wlan0: no IPv6 routers present
Oct 19 07:49:01 thibaud-AO722 kernel: [   39.088310] [drm:radeon_ib_schedule] *ERROR* radeon: couldn't schedule IB(4).
Oct 19 07:49:01 thibaud-AO722 kernel: [   39.088326] [drm:radeon_cs_ioctl] *ERROR* Failed to schedule IB !

After some quick research it appears I likely have the bug filed here : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1058303.

I am now wondering if I should use the old .30 kernel or the one provided in the bug report.

Thank you for your time and attention in advance !

Thibaud Ruelle

  • Mine has been doing this as well. Fresh install, just did the important updates and skipped the recommended ones to try to fix another problem. – Bryan Oct 8 '12 at 15:27
  • Thanks, I also made a new install and still have the issue. I edited for clarity, in hope that we will have more answers. – Thibaud Ruelle Oct 10 '12 at 11:47
  • Thanks, I'll investigate this. Funny I did not find it typing black screen here ... – Thibaud Ruelle Oct 10 '12 at 15:05
  • I added information following troubleshooting blank screen, however I cannot verify troubleshooting freeze since I do not have an ethernet access to my netbook. Moreover I would like to avoid installing upstream Xorg/kernel because I will most likely have trouble removing them. – Thibaud Ruelle Oct 11 '12 at 9:39

Just to fold this question properly.

The issue was caused by the following bug : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1058303, which has been corrected.

I do not experience this issue anymore. Thank you all for your help.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.