A while ago I tried upgrading from 12.04 to 12.04.1, I believe it was, and in the middle of it I lost power and my computer died. I tried resetting it and it was stuck on the black screen with the blinking cursor. Eventually I managed to recover it and get it sort of working through various terminal commands, but now I can't use Update Manager to update to the next version. Whenever I pull up Update Manager it gives me this message:

"Not all Updates can be installed

Run a partial upgrade, to install as many updates as possible"

And goes on to list possible causes of it and then gives me the option to do the partial upgrade or to close. Then a window comes up saying:

"Can not upgrade

An upgrade from 'precise' to 'oneiric' is not supported with this tool."

So how do I go about upgrading? Is my only option a fresh install?


I'm not sure if this will do much but they talk about doing upgrade by using command prompt but to version 12.04. Here is a link, and I will look for few more links that might be useful.

Here, first source and also second source.

I hope this will help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.