8

My mouse is not working properly, So I enabled keyboard keys for Moving mouse arrow using

Universal Access > Pointing and Clicking > Mouse keys "On"

But Mouse Arrow moves very Slow using keyboard Keys. I want to move it in normal way as I move mouse, using keyboard keys(Numlock keys 2,4,6,8). How can I solve this ?

3
  • Confirmed on an Ubuntu 12.10. Same problem: the cursor moves extremely slow when using the keyboard keys. Unfortunately, Fly's post didn't show any improvements. – somethis Aug 19 '13 at 8:11
  • I am having this same problem but this fix did not work for me. Please help. – user260478 Mar 21 '14 at 4:56
  • 2
    Possible duplicate of Adjust mouse keys in 12.04? – Byte Commander Jun 15 '16 at 19:27
4

It's more than likely the delay that you have set for they keyboard repeating keys.

  1. Go to "System Settings"
  2. Click on "Keyboard"
  3. Lower the "Delay" slider under "Repeat Keys"
  4. Raise the "Speed" slider under "Repeat Keys"

Comment back if this doesn't solve the problem.

2
  • 4
    This didn't solved it for me. Running 14.04. – Meetai.com Jul 17 '14 at 12:58
  • same with 17.04 – elect Jul 28 '17 at 20:36
6

I use these commands:

sudo apt-get install xkbset
xkbset ma 60 10 10 5 2
2
  • I don't have a numeric keypad, so I can't test your answer, but xkbset seems like a good solution here. It would be great if you could explain a little how to use xkbset and how you worked out these settings. – Zanna Sep 6 '17 at 6:58
  • 1
    To partially understand the settings, read the man page for xkbset and: en.wikipedia.org/w/… – davidvandebunte Mar 30 '19 at 11:14
3

Use gsettings to change the speed parameters keys.

  • To find these keys I used:

    gsettings list-recursively | grep keyboard | grep mouse
    

    I found:

    org.gnome.desktop.a11y.keyboard mousekeys-max-speed 10
    org.gnome.desktop.a11y.keyboard mousekeys-init-delay 300
    org.gnome.desktop.a11y.keyboard mousekeys-accel-time 300
    org.gnome.desktop.a11y.keyboard mousekeys-enable true
    
  • To know what each key does I use:

    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-max-speed;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-init-delay;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-accel-time;
    gsettings describe org.gnome.desktop.a11y.keyboard mousekeys-enable;
    
  • I performed the following procedure to change these keys:

    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-max-speed 2000;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-init-delay 20;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-accel-time 2000;
    gsettings set org.gnome.desktop.a11y.keyboard mousekeys-enable true;
    

These key values ​​are personal, you must enter the values ​​that are suitable for you.

The image below shows how to control your cursor: enter image description here

Source: https://www.repairwin.com/wp-content/uploads/2019/03/image-8.png

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.