I'd like the original colour scheme, icon style of 12.04.

I somehow lost the Ambiance theme (possible error or upgrade error). I re-installed 'light-themes' from the terminal and got it back.

But the panel on the top that shows the options of sound, battery and wi-fi has changed and I can-not get the original setting back.

In the windows, the close, minimize tools have shifted to the right instead of the original left side.

I had installed MyUnity and Ubuntu Tweak but deleted them. As such, I want the original setting back.

Kindly help me with the commands.

I have searched for solutions; there are multiple and I need to be sure if I should follow the same. Kindly bear before marking duplicate.


  • The appearance is gray and boxy as outlined here. Not sure same problem.

  • Similar 'gray and boxy' article here.

  • Desktop forgets theme.

  • I have also tried the unity --reset command. It never completes. I gave it 20 minutes.


3 Answers 3


Open terminal Ctrl+Alt+T and run following command:

Reset Icon Pack

gsettings set org.gnome.desktop.interface icon-theme ''

Reset Theme

gsettings set org.gnome.desktop.interface gtk-theme ''

gsettings set org.gnome.desktop.wm.preferences theme ''

gconftool-2 --set --type string /apps/metacity/general/theme ''

Reset Launcher

gsettings reset com.canonical.Unity.Launcher favorites

Reset Panel

gsettings set com.canonical.Unity.Panel systray-whitelist "['all']" 

After run this command logout and login back.

  • 1
    Worked perfectly. Thank you @penreturn for your assistance. This makes Ubuntu look good again. There are other threads on similar lines, shall go there and redirect them here. It may help them. Sep 30, 2012 at 21:19
  • Great! Enjoy Ubuntu Sir!
    – penreturns
    Sep 30, 2012 at 21:21
  • 1
    +1 Nice answer. I deleted mine as it was completely wrong. D'oh! Sep 30, 2012 at 21:23
  • This just made my terminal completely black and I was unable to read anything then all the text turn black Jan 8, 2016 at 21:00
  • This did not work for me, but replacing all the '' with the theme name did. For example, gsettings set org.gnome.desktop.interface icon-theme 'Ambiance'
    – cs01
    Mar 16, 2016 at 17:46

Try running the following command from a Terminal (Ctrl+Alt+T).

unity --reset-icons

This will reset the Unity icon cache.


What you can do is reinstall MyUnity and open up the themes menu. There is a button to reset it to the defaults, but you can manually set the theme to "Ambiance" and the icon theme to "Ubuntu-Mono-Dark" and that should bring you back to the default 12.04 set-up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.